Bug 732164 - grub version in f16 beta does not detect md devices properly
grub version in f16 beta does not detect md devices properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 732133 (view as bug list)
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-08-20 03:21 EDT by Rudolf Kastl
Modified: 2011-10-14 15:36 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-14 15:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2011-08-20 03:21:36 EDT
Description of problem:
I actually have two identical harddrives partitioned as follows
sd[ab]1 - 1mb fixed size - bios boot - forced primary
sd[ab]2 - 500mb fixed size - softraid mirror md0 with ext4 - /boot - forced primary
sd[ab]3 - the rest of the drive size in fixed size - softraid mirror md1 with lvm containing / /home and swap as lv
the installation went through and showed no error -> installation didnt boot

----

i did to setup a changeroot with the livecd to analyse the problem:

    [root@localhost ~]# ls -l /dev/md0
    brw-rw----. 1 root disk 9, 0 Aug 20 03:55 /dev/md0
     
    [root@localhost ~]# blkid |grep md0
    /dev/md0: UUID="b07c4b97-fd37-43d3-91ce-8ebfeb7aeb07" TYPE="ext4"
     
    [root@localhost ~]# grub2-install /dev/sda/usr/sbin/grub2-probe: error: no such disk.
    Auto-detection of a filesystem of /dev/md0 failed.
    Please report this together with the output of "/usr/sbin/grub2-probe --device-map="/boot/grub2/device.map" --target=fs -v /boot/grub2" to <bug-grub@gnu.org>
     
    [root@localhost ~]# /usr/sbin/grub2-probe --device-map="/boot/grub2/device.map" --target=fs -v /boot/grub2
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: scanning hd0 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: scanning hd1 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: scanning hd2 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: scanning hd3 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: scanning md/0 for LVM.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning md/1 for LVM.
    /usr/sbin/grub2-probe: info: scanning hd0 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: scanning hd0,gpt3 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd0,gpt2 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd0,gpt1 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd0 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd1 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: scanning hd1,gpt3 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd1,gpt2 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd1,gpt1 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd1 is 3907029168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd2 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: scanning hd2,msdos1 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd2 is 1465149168.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: scanning hd3 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: scanning hd3,msdos1 for LVM.
    /usr/sbin/grub2-probe: info: the size of hd3 is 4042752.
    /usr/sbin/grub2-probe: info: no LVM signature found
    .
    /usr/sbin/grub2-probe: info: changing current directory to /dev.
    /usr/sbin/grub2-probe: info: opening md0.
    /usr/sbin/grub2-probe: error: no such disk.

after that i researched and figured that 1.99 final release uses mduuid/... not md/... and can actually properly make it boot.

please upgrade grub2 to 1.99 final or pull in the fix from upstream to make it possible to have /boot on a md mirror. the setup is working now with grub 1.99 final without any additional patches.

Version-Release number of selected component (if applicable):
grub2-1.99-0.2.fc16.x86_64

How reproducible:
always
Comment 1 John Dulaney 2011-08-26 11:49:13 EDT
I'm going to say that this is a Final blocker, blocking Final Criteria #5:  "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above.".
Comment 2 Tim Flink 2011-09-01 13:46:45 EDT
Discussed in the 2011-08-26 blocker review meeting. Accepted as a Fedora 16 final blocker as it violates the following final release criterion [1]:

The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above.

[1] https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
Comment 3 Fedora Admin XMLRPC Client 2011-09-16 15:08:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Jerry Amundson 2011-09-23 21:40:43 EDT
*** Bug 732133 has been marked as a duplicate of this bug. ***
Comment 5 Jerry Amundson 2011-09-23 22:02:24 EDT
I'm not sure what "1.99 final" is (will be), but my upgrade with grub2-1.99-6.fc16.i686 fails at next boot.
Comment 6 Jerry Amundson 2011-09-23 22:49:33 EDT
(In reply to comment #5)
> I'm not sure what "1.99 final" is (will be), but my upgrade with
> grub2-1.99-6.fc16.i686 fails at next boot.

I should clarify - that version is from the 16-Beta.RC1 rescue mode "chroot /mnt/sysimage".

I'm keeping this system "as is" for testing purposes, though I'm not happy about it... :-)

From bug #732133 comment 5,
(In reply to comment #5)
> But I can now boot with:
> set prefix=(hd0,gpt2)/boot/grub2
> set root=(hd0,gpt2)
> linux /boot/vmlinuz... root=/dev/md0 ro
> initrd /boot/initramfs...
> boot

My "linux" and "initrd" commands fail at the grub-rescue prompt.
Comment 7 Jerry Amundson 2011-10-06 20:26:51 EDT
My particular issue was resolved by:
- updates
- grub2-mkconfig -o /boot/grub2/grub.cfg
- grub2-install /dev/sda && grub2-install /dev/sdb
- some combination of the above
Comment 8 Adam Williamson 2011-10-14 15:36:53 EDT
1.99 'final' made f16 quite some time ago, so let's close this. But Rudolf, can you let us know if you're able to install Beta or Final TC1 (when it lands) to the affected system? Thanks. If not, can you check if the problem now seems to be the same as https://bugzilla.redhat.com/show_bug.cgi?id=743273 ?

Note You need to log in before you can comment on or make changes to this bug.