Bug 73220 - httpd dies on receipt of a HUP signal
httpd dies on receipt of a HUP signal
Status: CLOSED DUPLICATE of bug 66613
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Depends On:
  Show dependency treegraph
Reported: 2002-08-31 22:41 EDT by Reuben Farrelly
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-04 14:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2002-08-31 22:41:52 EDT
From Bugzilla Helper:

Description of problem:
Apache dies when logs are rotated as part of logrotate.d (the weekly logrotate 
sends apache a HUP)

Version-Release number of selected component (if applicable):
[root@tornado linux-2.5]# rpm -q httpd
httpd-2.0.40-4  (but this applies to previous versions of httpd-2 as well)

How reproducible:

Steps to Reproduce:
1. Wait for 4am Sunday morning after the weekly logrotate runs
2. Wake up and find that httpd is no longer running ;-)

Expected Results:  Apache should have rotated logs and not died

Additional info:

This can be manually triggered:

[root@tornado root]# /etc/init.d/httpd status 
httpd (pid 17755 17754 17753 17752 17751 17748) is running...
[root@tornado root]# kill -HUP `cat /var/run/httpd.pid`
[root@tornado root]# /etc/init.d/httpd status          
httpd dead but pid file exists
[root@tornado root]#
[root@tornado root]# /etc/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd:                                            [  OK  ]
[root@tornado root]#
Comment 1 Joe Orton 2002-09-01 05:25:19 EDT
Are you using PHP or any other modules? If so, what version of the PHP package?
Comment 2 Reuben Farrelly 2002-09-01 05:28:52 EDT
Yes, using PHP:


No other modules other than the default install AFAIK.
Comment 3 Joe Orton 2002-09-01 05:45:45 EDT
Can you still reproduce this if you disable PHP? e.g.

 # cd /etc/httpd/conf.d
 # mv php.conf php.conf.disabled
 # service httpd restart

Comment 4 Reuben Farrelly 2002-09-01 05:50:02 EDT
You've obviously struck something like this before ;-)
Yes it seems to be fine if PHP is disabled...
Comment 5 Joe Orton 2002-09-02 16:35:42 EDT
Yes, we've seen this before... what system are you testing on here - Limbo,
Null, 7.3?
Comment 6 Reuben Farrelly 2002-09-02 18:55:24 EDT
Yes, running Null (with all up2date updates applied).
Comment 7 Phil Copeland 2002-09-03 04:08:59 EDT
*grumble* ok
I can finally reproduce this. I still say it was something in httpd though

Basically it'll trigger on the *SECOND* sighup to httpd not the first and only
if libphp4.so is loaded. Oddly the segv is NOT in any php related code. Smells
like a httpd bug, however, I've been advised that disabling zts support in php
fixes this.

service httpd start (ok)
apachectl restart (ok)
apachectl restart (fails)

Humm,... compiled without zts,.. php segv's httpd segv's worse state of affairs.
... and this is going to have to be fixed in <10 hours??!?
God, I'm so doomed. 8/

Comment 8 Phil Copeland 2002-09-03 11:56:58 EDT
Fixed in 4.2.2-8.0.5 though root cause not found

Comment 9 Joe Orton 2002-09-04 13:23:00 EDT
We're actually still tracking this down - what other modules do you have loaded?
Results of "ls /etc/httpd/conf.d" could be useful data.
Comment 10 Gary Benson 2002-09-04 14:02:06 EDT

*** This bug has been marked as a duplicate of 66613 ***

Note You need to log in before you can comment on or make changes to this bug.