Bug 732226 - "Thermal Shutdown Occurred" message arises every time booting system
Summary: "Thermal Shutdown Occurred" message arises every time booting system
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: John Feeney
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 03:06 UTC by Fangwen Yu
Modified: 2013-01-10 08:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-06 18:58:16 UTC


Attachments (Terms of Use)
output of the shell script (272 bytes, text/plain)
2011-08-24 01:41 UTC, Fangwen Yu
no flags Details
output of dmesg (60.60 KB, text/plain)
2011-08-24 01:42 UTC, Fangwen Yu
no flags Details
output of acpidump (299.59 KB, text/plain)
2011-08-26 01:21 UTC, Fangwen Yu
no flags Details
output of dmesg(new version) (74.53 KB, text/plain)
2011-10-10 15:20 UTC, Fangwen Yu
no flags Details

Description Fangwen Yu 2011-08-21 03:06:29 UTC
Description of problem:
Every time I boot my system, I would get a message says:

Thermal Shutdown Occurred
The system BIOS has detected that your notebook PC was put into hibernation or shutdown to avoid overheating. The system is now operating normally.
Overheating may occurred if the cooling vents are blocked or the operating temperature exceeds the specifications. The system should return to normal once the situation is resolved.

After a few seconds, it boots into Fedora 15.

Version-Release number of selected component (if applicable):
Fedora (2.6.40.3-0.fc15.i686)

How reproducible:
Every time

Steps to Reproduce:
1.Boot system.
2.
3.
  
Actual results:
It never shuts down due to temperature related problems actually, but the warning message is annoying.

Expected results:
Boot smoothly with no warning message.


Additional info:
My laptop is a new one, so it couldn't be the cooling vents reason.
This problem also occurred with Ubuntu, Debian as far as I have tried, but not with Windows.
If I add "acpi=off" to the boot options, the warning message would disappear.
My hardware:
Processor: 2.1 GHz Intel Core i3-2310M
Video card: an ATI Radeon HD6470M and an Intel GMA HD integrated graphic chipset

Comment 1 Dave Jones 2011-08-23 15:26:27 UTC
What laptop model is it ?

Can you attach the output of this script..

#!/bin/sh

for dir in /sys/class/thermal/thermal_zone*
do
	echo $dir

	for i in mode passive temp trip_point_0_temp trip_point_0_type type
	do
		echo -n $i:
		cat $dir/$i
	done

	echo
done


also attach the output of dmesg.

Comment 2 Fangwen Yu 2011-08-24 01:41:06 UTC
Created attachment 519540 [details]
output of the shell script

I ran it from Live CD.

Comment 3 Fangwen Yu 2011-08-24 01:42:25 UTC
Created attachment 519542 [details]
output of dmesg

I ran it from Live CD.

Comment 4 Fangwen Yu 2011-08-24 01:46:05 UTC
My laptop is an HP Pavilion g4-1016tx.

Comment 5 Dave Jones 2011-08-24 03:46:07 UTC
There are numerous ACPI bugs reported in that dmesg.
The one most relevant to your thermal issue is this ..

[    1.363735] [Firmware Bug]: Invalid critical threshold (0)

As it suggests, it's a firmware bug, not a kernel bug so we can't do anything about it.  See if there's a BIOS update available from HP.

Comment 6 Matthew Garrett 2011-08-24 17:53:46 UTC
Also, could you install the pmtools package, run acpidump as root and attach the output?

Comment 7 Fangwen Yu 2011-08-26 01:21:36 UTC
Created attachment 519998 [details]
output of acpidump

Comment 8 Matthew Garrett 2011-08-29 13:15:54 UTC
Ok, I think I see the problem. Working on it now.

Comment 9 James Foster 2011-09-11 15:13:31 UTC
I have a HP Envy 17" 3D running Ubuntu 11.04 and I'm having this same issue....any solution yet

Comment 10 Fangwen Yu 2011-09-30 09:24:29 UTC
Today I tried Fedora 16 Alpha from Live CD, and the problem still exists.
By the way, my BIOS vendor is Insyde.

Comment 11 Fangwen Yu 2011-10-10 15:20:57 UTC
Created attachment 527257 [details]
output of dmesg(new version)

Comment 12 Fangwen Yu 2011-10-10 15:26:42 UTC
I updated my BIOS to the latest version today, and it solved my problem. Now I can boot smoothly without that annoying message.
But there are still some ACPI Errors and a firmware bug in the output of dmesg.


Note You need to log in before you can comment on or make changes to this bug.