Bug 73223 - Anaconda doesn't support terabye disk
Summary: Anaconda doesn't support terabye disk
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 04:39 UTC by hjl
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 04:40:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch for terabyte disk (2.18 KB, patch)
2002-09-01 04:40 UTC, hjl
no flags Details | Diff

Description hjl 2002-09-01 04:39:23 UTC
Anaconda doesn't support terabye disk
since it does

        totalSectors = float(disk.dev.heads
                             * disk.dev.sectors
                             * disk.dev.cylinders)

It is a big no-no. I am uploading a patch.

Comment 1 hjl 2002-09-01 04:40:05 UTC
Created attachment 74384 [details]
A patch for terabyte disk

Comment 2 Michael Fulbright 2002-09-02 15:14:33 UTC
Python 2 handles all this correctly so its fixed in 'null'.


Note You need to log in before you can comment on or make changes to this bug.