Bug 732236 - retrace-server using up all diskspace and bandwidth quota
Summary: retrace-server using up all diskspace and bandwidth quota
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: retrace-server
Version: 14
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michal Toman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 07:30 UTC by Kerry
Modified: 2015-03-23 00:41 UTC (History)
5 users (show)

Fixed In Version: retrace-server-1.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 05:31:26 UTC


Attachments (Terms of Use)

Description Kerry 2011-08-21 07:30:31 UTC
Description of problem:
I just ran out of disk space and used up 50 gigs of my download quota (of 100 gigs for the month) in a single day. Luckily I caught it using up my disk space as I was watching it and found these processes running:

retrace 29334 29323 0 12:00 ? 00:00:00 /bin/sh -c /usr/bin/retrace-server-reposync fedora 15 i386 >> /var/log/retrace-server/reposync_error.log 2>&1
retrace 29336 29334 0 12:00 ? 00:00:00 /usr/bin/python /usr/bin/retrace-server-reposync fedora 15 i386
retrace 15218 29336 0 15:46 ? 00:00:00 rsync -t rsync://ftp.sh.cvut.cz/fedora/linux/releases/15/Everything/i386/debug/* /var/cache/retrace-server/fedora-15-i386
retrace 15226 15218 4 15:46 ? 00:00:14 rsync -t rsync://ftp.sh.cvut.cz/fedora/linux/releases/15/Everything/i386/debug/* /var/cache/retrace-server/fedora-15-i386

Looking at the result, it looks as though it is using up a lot of gigabytes of disk space (as well as my bandwidth to download them).
[root@politemadness retrace-server]# du -h
4.0K ./fedora-15-x86_64/repodata
4.0K ./fedora-15-x86_64/.repodata
908K ./fedora-15-x86_64
4.0K ./fedora-15-i386/.repodata
4.0K ./fedora-15-i386/repodata
17G ./fedora-15-i386
17G .
(I had already deleted the 30 something gigabytes of packages it had downloaded into fedora-15-x86_64.)

It only gave up where it did because it crashed when I ran out of disk space.

I see that there is a cron job for this:
# cat /var/spool/cron/retrace
0 0,12 * * * /usr/bin/retrace-server-reposync fedora 15 i386 >> /var/log/retrace-server/reposync_error.log 2>&1
0 4,16 * * * /usr/bin/retrace-server-reposync fedora 15 x86_64 >> /var/log/retrace-server/reposync_error.log 2>&1

Mostly, this is quite ridiculous. Nothing should be running automagically behind the scenes that is this resource intensive. I did try running crashes locally, but nowhere in anything did it tell me it was going to download every package as well as architectures which don't run on my PC (x86_64).

Version-Release number of selected component (if applicable):
retrace-server.noarch 0:1.2-1.fc15

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Toman 2011-08-22 06:35:37 UTC
You are absolutely right, this should not be enabled by default. I figured this out a few days ago and the problem is already fixed in git. The new version of Retrace server should land in updates-testing today or tomorrow.

Comment 2 Fedora Update System 2011-08-23 10:35:32 UTC
retrace-server-1.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/retrace-server-1.3-1.fc15

Comment 3 Fedora Update System 2011-08-23 18:49:04 UTC
Package retrace-server-1.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing retrace-server-1.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/retrace-server-1.3-1.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-09-02 05:31:20 UTC
retrace-server-1.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.