Bug 73226 - gnome-terminal has serious memory leak (even when idle)
gnome-terminal has serious memory leak (even when idle)
Status: CLOSED DUPLICATE of bug 76219
Product: Red Hat Linux
Classification: Retired
Component: Xft (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-01 04:03 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
memprof profile and leak saved data (303.80 KB, text/plain)
2002-09-01 04:04 EDT, Michael Lee Yohe
no flags Details

  None (edit)
Description Michael Lee Yohe 2002-09-01 04:03:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Long sessions with gnome-terminal open will consume a very large portion of the
available system memory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The easiest method to see the allocation happen while Gnome Terminal is active
is to use "memprof" - otherwise, leave a couple terminal sessions open and
browse "top" once in a while.

1.  From the run box type "memprof gnome-terminal"
2.  Once memprof is running, do a couple things in gnome-terminal (list a
directory, run "top" - things to fill the scrollback buffer).
3.  Exit all running applications so that only the shell is running (go back to
the prompt).
4.  Switch back to memprof and allow gnome-terminal to run idle.  Two
allocations are made about every second the terminal is idle.
	

Actual Results:  After running a gnome-terminal session (even worse if multiple
sessions are open an idle), gnome-terminal will continue to allocate memory
until swap is depleted (six gnome-terminal sessions on my machine after a few
days ate 160+M of physical memory and 950+M of swap).

Expected Results:  gnome-terminal should only allocate memory necessary for its
operation and its scrollback buffer.

Additional info:

Red Hat Linux 7.3.94 (null) beta
System is up2date
gnome-terminal package is 2.0.1-3

384M physical
1G swap
Comment 1 Michael Lee Yohe 2002-09-01 04:04:47 EDT
Created attachment 74404 [details]
memprof profile and leak saved data
Comment 2 Nalin Dahyabhai 2002-09-02 13:04:30 EDT
Yep, still trying to pin this one down.  What I do know is that it stops
happening if you disable the blinking cursor, but I haven't tracked it any
closer than that.
Comment 3 Need Real Name 2002-09-19 13:19:26 EDT
Disabling anti-aliased fonts also seems to help this problem (it does for me).

Scrolling around in the scroll-back buffer worsens the problem, so I guess
something with font drawing is not OK ... also, the X process is bloating up
beyond normal when doing this.
Comment 4 Need Real Name 2002-10-07 06:09:50 EDT
BTW I don't have the RENDER extension (I830).

Cheers
Tycho
Comment 5 Michael Lee Yohe 2002-11-18 12:50:14 EST
A temporary solution to this problem is to download "dzt" (found at
http://dzt.sourceforget.net).  It's a native GTK+ 1.2 application (no
anti-aliased fonts - YAY), highly configurable, and features tab support.  It
has a small memory profile - and isn't susceptible to the nasty leaks found in vte.
Comment 6 Nalin Dahyabhai 2003-05-15 16:28:50 EDT
Hmm, actually a bug in Xft.  Marking as a duplicate of the bug filed against Xft.

*** This bug has been marked as a duplicate of 76219 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:49:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.