Bug 732271 - plasma4 dependency not resolved
plasma4 dependency not resolved
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-21 09:28 EDT by darrell pfeifer
Modified: 2011-09-26 13:02 EDT (History)
9 users (show)

See Also:
Fixed In Version: kdebase-workspace-4.7.0-8.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-21 19:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2011-08-21 09:28:46 EDT
Description of problem:

--> Running transaction check
---> Package kdebase-workspace.x86_64 0:4.7.0-7.fc17 will be an update
--> Processing Dependency: plasma4(scriptengine-dashboard) for package: kdebase-workspace-4.7.0-7.fc17.x86_64
--> Processing Dependency: plasma4(scriptengine-webkit) for package: kdebase-workspace-4.7.0-7.fc17.x86_64
---> Package libdb.i686 0:5.2.28-2.fc16 will be installed
---> Package nss-softokn.i686 0:3.12.11-2.fc17 will be installed
--> Processing Dependency: libsqlite3.so.0 for package: nss-softokn-3.12.11-2.fc17.i686
--> Running transaction check
---> Package kdebase-workspace.x86_64 0:4.7.0-7.fc17 will be an update
--> Processing Dependency: plasma4(scriptengine-dashboard) for package: kdebase-workspace-4.7.0-7.fc17.x86_64
--> Processing Dependency: plasma4(scriptengine-webkit) for package: kdebase-workspace-4.7.0-7.fc17.x86_64
---> Package sqlite.i686 0:3.7.7.1-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: kdebase-workspace-4.7.0-7.fc17.x86_64 (koji)
           Requires: plasma4(scriptengine-webkit)
Error: Package: kdebase-workspace-4.7.0-7.fc17.x86_64 (koji)
           Requires: plasma4(scriptengine-dashboard)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Kevin Kofler 2011-08-21 17:46:35 EDT
That'd be my fault, let me have a look at it.
Comment 2 Rex Dieter 2011-08-21 17:51:48 EDT
Seeing the commits land, I was almost going to suggest enabling the Provides pieces for awhile prior to the Requires bits, but otoh, doing them at the same time will clearly highlight what needs fixing. :-/
Comment 3 Kevin Kofler 2011-08-21 17:55:33 EDT
This is because:
/usr/share/kde4/services/plasma-scriptengine-applet-dashboard.desktop
/usr/share/kde4/services/plasma-scriptengine-applet-web.desktop
have:
ServiceTypes=Plasma/ScriptEngine
which should be:
X-KDE-ServiceTypes=Plasma/ScriptEngine
and so the .desktop files are not correctly detected as belonging to a script engine.
Comment 4 Kevin Kofler 2011-08-21 18:14:02 EDT
https://fedorahosted.org/kde-settings/changeset/271

This will be fixed in a few minutes when I'll have built a new kde-settings and rebuilt kdebase-workspace against it.
Comment 5 Kevin Kofler 2011-08-21 18:44:43 EDT
Fixed kde-settings build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=259797
Comment 6 Kevin Kofler 2011-08-21 19:25:48 EDT
kdebase-workspace-4.7.0-8.fc17 built successfully, bug verified fixed (there are now Provides instead of the Requires, because the files with the X-Plasma-API entry are the script engine itself), closing.
Comment 7 Fedora Update System 2011-09-26 12:16:56 EDT
akonadi-1.6.1-1.fc16, blinken-4.7.1-2.fc16, cantor-4.7.1-2.fc16, gwenview-4.7.1-2.fc16, kalgebra-4.7.1-1.fc16, kalzium-4.7.1-1.fc16, kamera-4.7.1-1.fc16, kanagram-4.7.1-1.fc16, kate-4.7.1-1.fc16, kbruch-4.7.1-2.fc16, kcolorchooser-4.7.1-1.fc16, kdeaccessibility-4.7.1-1.fc16, kdeadmin-4.7.1-2.fc16, kdeartwork-4.7.1-1.fc16, kdebase-4.7.1-2.fc16, kdebase-runtime-4.7.1-1.fc16, kdebase-workspace-4.7.1-2.fc16, kdeedu-4.7.1-2.fc16, kdegames-4.7.1-1.fc16, kdegraphics-4.7.1-1.fc16, kdegraphics-strigi-analyzer-4.7.1-1.fc16, kdegraphics-thumbnailers-4.7.1-1.fc16, kde-l10n-4.7.1-1.fc16, kdelibs-4.7.1-1.fc16, kdemultimedia-4.7.1-4.fc16, kdenetwork-4.7.1-1.fc16, kdepim-4.7.1-1.fc16, kdepimlibs-4.7.1-1.fc16, kdepim-runtime-4.7.1-4.fc16, kdeplasma-addons-4.7.1-1.fc16, kdesdk-4.7.1-1.fc16, kde-settings-4.7-7.fc16, kdetoys-4.7.1-1.fc16, kdeutils-4.7.1-1.fc16, kgamma-4.7.1-1.fc16, kgeography-4.7.1-2.fc16, khangman-4.7.1-2.fc16, kig-4.7.1-2.fc16, kiten-4.7.1-2.fc16, klettres-4.7.1-2.fc16, kmplot-4.7.1-2.fc16, kolourpaint-4.7.1-1.fc16, konsole-4.7.1-1.fc16, kross-interpreters-4.7.1-1.fc16, kruler-4.7.1-1.fc16, ksaneplugin-4.7.1-1.fc16, ksnapshot-4.7.1-1.fc16, kstars-4.7.1-3.fc16, ktouch-4.7.1-2.fc16, kturtle-4.7.1-2.fc16, kwordquiz-4.7.1-2.fc16, libkdcraw-4.7.1-1.fc16, libkdeedu-4.7.1-1.fc16, libkexiv2-4.7.1-1.fc16, libkipi-4.7.1-1.fc16, libksane-4.7.1-1.fc16, marble-4.7.1-1.fc16, okular-4.7.1-2.fc16, oxygen-icon-theme-4.7.1-1.fc16, parley-4.7.1-2.fc16, PyKDE4-4.7.1-2.fc16, rocs-4.7.1-3.fc16, shared-desktop-ontologies-0.8.0-1.fc16, smokegen-4.7.1-1.fc16, smokekde-4.7.1-2.fc16, smokeqt-4.7.1-2.fc16, step-4.7.1-2.fc16, svgpart-4.7.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/akonadi-1.6.1-1.fc16,blinken-4.7.1-2.fc16,cantor-4.7.1-2.fc16,gwenview-4.7.1-2.fc16,kalgebra-4.7.1-1.fc16,kalzium-4.7.1-1.fc16,kamera-4.7.1-1.fc16,kanagram-4.7.1-1.fc16,kate-4.7.1-1.fc16,kbruch-4.7.1-2.fc16,kcolorchooser-4.7.1-1.fc16,kdeaccessibility-4.7.1-1.fc16,kdeadmin-4.7.1-2.fc16,kdeartwork-4.7.1-1.fc16,kdebase-4.7.1-2.fc16,kdebase-runtime-4.7.1-1.fc16,kdebase-workspace-4.7.1-2.fc16,kdeedu-4.7.1-2.fc16,kdegames-4.7.1-1.fc16,kdegraphics-4.7.1-1.fc16,kdegraphics-strigi-analyzer-4.7.1-1.fc16,kdegraphics-thumbnailers-4.7.1-1.fc16,kde-l10n-4.7.1-1.fc16,kdelibs-4.7.1-1.fc16,kdemultimedia-4.7.1-4.fc16,kdenetwork-4.7.1-1.fc16,kdepim-4.7.1-1.fc16,kdepimlibs-4.7.1-1.fc16,kdepim-runtime-4.7.1-4.fc16,kdeplasma-addons-4.7.1-1.fc16,kdesdk-4.7.1-1.fc16,kde-settings-4.7-7.fc16,kdetoys-4.7.1-1.fc16,kdeutils-4.7.1-1.fc16,kgamma-4.7.1-1.fc16,kgeography-4.7.1-2.fc16,khangman-4.7.1-2.fc16,kig-4.7.1-2.fc16,kiten-4.7.1-2.fc16,klettres-4.7.1-2.fc16,kmplot-4.7.1-2.fc16,kolourpaint-4.7.1-1.fc16,konsole-4.7.1-1.fc16,kross-interpreters-4.7.1-1.fc16,kruler-4.7.1-1.fc16,ksaneplugin-4.7.1-1.fc16,ksnapshot-4.7.1-1.fc16,kstars-4.7.1-3.fc16,ktouch-4.7.1-2.fc16,kturtle-4.7.1-2.fc16,kwordquiz-4.7.1-2.fc16,libkdcraw-4.7.1-1.fc16,libkdeedu-4.7.1-1.fc16,libkexiv2-4.7.1-1.fc16,libkipi-4.7.1-1.fc16,libksane-4.7.1-1.fc16,marble-4.7.1-1.fc16,okular-4.7.1-2.fc16,oxygen-icon-theme-4.7.1-1.fc16,parley-4.7.1-2.fc16,PyKDE4-4.7.1-2.fc16,rocs-4.7.1-3.fc16,shared-desktop-ontologies-0.8.0-1.fc16,smokegen-4.7.1-1.fc16,smokekde-4.7.1-2.fc16,smokeqt-4.7.1-2.fc16,step-4.7.1-2.fc16,svgpart-4.7.1-1.fc16
Comment 8 Kevin Kofler 2011-09-26 13:02:05 EDT
Ignore the above comment, this issue did not affect Fedora 16 (and it's already fixed in Rawhide).

Note You need to log in before you can comment on or make changes to this bug.