Bug 732281 - System boot failed after creating new initramfs w/ initial distro kernel and other
Summary: System boot failed after creating new initramfs w/ initial distro kernel and ...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 15
Hardware: i686
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: dracut-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 15:21 UTC by hchickers
Modified: 2012-01-23 09:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-23 09:23:41 UTC


Attachments (Terms of Use)
dmesg | grep dracut (53.77 KB, text/plain)
2011-08-22 11:45 UTC, hchickers
no flags Details
cat /run/initramfs/init.log (7.34 KB, application/x-gzip)
2011-08-22 11:50 UTC, hchickers
no flags Details

Description hchickers 2011-08-21 15:21:44 UTC
Description of problem:Fresh install, system boots OK. Applied all updates as off 8/20/11, tried to boot kernel 2.6.40.3-0 PAE got dropped to a dracut shell. Rebooted to initial distro kernel, 2.6.38.6-26.rc1 PAE, booted OK. Rebuilt initramfs for the initial distro kernel, dracut -f /boot/initramfs-2.6.38.6-26.rc1.fc15.i686.PAE.img 2.6.38.6-26.rc1.fc15.i686.PAE. On reboot it drops to a dracut shell. From rescue tried to rebuild initramfs w/ various options like --lvmconf --mdadmconf etc. same result, cannot boot. Also tried different versions of dracut, the stock one, the one in updates and also one from testing FC16 w/ the same results. Before dropping to the dracut shell I get a warning message saying that it cannot find the root device vg00/lv01. In dracut shell blkid shows only /dev/sda, mdadm --assemble --scan doesn't do anything, /proc/mdstat shows no info about any of the RAID devices, the system doesn't ask for LUKS password, lvm vgscan returns nothing.

System config: HP xw8400 workstation, 14GB RAM, 2x 300GB disk RAID 1 (md127), 2x 500GB disk RAID 1 (md126), LUKS and LVM


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Please see above
2.
3.
  
Actual results:
System doesn't boot

Expected results:
Normal boot

Additional info: Please see above

Comment 1 Harald Hoyer 2011-08-22 09:09:23 UTC
more info please:
http://www.kernel.org/pub/linux/utils/boot/dracut/dracut.html#id538329

Comment 2 hchickers 2011-08-22 11:44:50 UTC
Hi
Sorry for not including the proper info w/ the issue. Please see below:

dracut:/# less /proc/cmdline
ro root=/dev/mapper/vg00-lv01 rd_LUKS_UUID=luks-798c610a-cd1a-4356-8041-5a4a2d0ace4d rd_MD_UUID=a1a48881:20c5474d:4649e0e1:c6429512 rd_LVM_LV=vg00/lv01 rd_LVM_LV=vg00/lv00 LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTA
BLE=us nouveau.modeset=0 rdblacklist=nouveau rd.debug console=tty0 console=ttyS0,115200

dracut:/# dmsetup ls --tree
No devices found
dracut:/# blkid -p
The low-level probing mode requires a device
dracut:/# blkid
/dev/sda: TYPE="isw_raid_member" 
dracut:/# blkid -p -o udev
The low-level probing mode requires a device

dracut:/# lvm pvdisplay
File descriptor 9 (/.console_lock) leaked on lvm invocation. Parent PID 933: sh
dracut:/# lvm vgdisplay
File descriptor 9 (/.console_lock) leaked on lvm invocation. Parent PID 933: sh
  No volume groups found
dracut:/# lvm lvdisplay
File descriptor 9 (/.console_lock) leaked on lvm invocation. Parent PID 933: sh
  No volume groups found
dracut:/# cat /proc/mdstat
Personalities : 
unused devices: <none>

Also the output from dmesg|grep dracut attached
Thanks
HC

Comment 3 hchickers 2011-08-22 11:45:57 UTC
Created attachment 519265 [details]
dmesg | grep dracut

The dmesg|grep dracut output. Please let me know if you need additional info.
Thanks,
HC

Comment 4 hchickers 2011-08-22 11:50:27 UTC
Created attachment 519267 [details]
cat /run/initramfs/init.log

additional info, results of cat /run/initramfs/init.log. Hope this helps
Thanks,
HC

Comment 5 hchickers 2011-08-22 12:02:43 UTC
Copy of fstab, sorry I forgot to send it easlier

#
# /etc/fstab
# Created by anaconda on Sat Aug 20 09:31:29 2011
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg00-lv01   /                       ext4    defaults        1 1
UUID=7c09b17e-05a6-434d-8469-fc79f130a821 /boot                   ext4    defaults        1 2
/dev/mapper/vg00-lv07   /home                   ext4    defaults        1 2
/dev/mapper/vg00-lv05   /opt                    ext4    defaults        1 2
/dev/mapper/vg00-lv06   /tmp                    ext4    defaults        1 2
/dev/mapper/vg01-lv00   /u101                   ext4    defaults        1 2
/dev/mapper/vg01-lv01   /u102                   ext4    defaults        1 2
/dev/mapper/vg01-lv02   /u103                   ext4    defaults        1 2
/dev/mapper/vg00-lv02   /usr/local              ext4    defaults        1 2
/dev/mapper/vg00-lv03   /var                    ext4    defaults        1 2
/dev/mapper/vg00-lv04   /var/log                ext4    defaults        1 2
/dev/mapper/vg00-lv00   swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0

Additional info:

2x300GB = md127, partitioned as md127p1 = ext4 mounted as /boot; md127p2 = lvm partition encrypted, member of vg00 exclusively

2x500GB = md126, partition md126p1 = lvm partition encrypted, member of vg01 exclusively

Hope this helps
Thanks,
HC

Comment 6 Harald Hoyer 2011-08-22 12:15:54 UTC
I think "mdadm" lost it's capability to assemble IMSM raid devices, also known as "isw_raid_member".

Could you remove "rd_MD_UUID=a1a48881:20c5474d:4649e0e1:c6429512" and add "rd_NO_MDIMSM" to the kernel command line?

Comment 7 hchickers 2011-08-22 14:51:17 UTC
Hi
Did that, it gets a little further but it still drops me into the dracut shell. Sorry, I cannot provide additional info at this point, I am at work, but as soon as I get home (PM EDT) I'll gather the needed info and attach it here. Is it any specific info that you need, not sure if I have to go over attaching all as above anymore ? 

Another piece of info, I have added rd_NO_DM to the kernel line and it doesn't drop me to the shell anymore but it doesn't boot up all the way either. Looks like it calls for systemd and it says something about dependencies not met when fsck-ing the filesystems and then stays there w/o doing anything. Also, before systemd I need to hit a key to get the prompt for LUKS password.

Hope this helps, I'll come back w/ more info later today

Thanks,
HC

Comment 8 Harald Hoyer 2011-08-22 15:13:45 UTC
(In reply to comment #7)
> Hi
> Did that, it gets a little further but it still drops me into the dracut shell.
> Sorry, I cannot provide additional info at this point, I am at work, but as
> soon as I get home (PM EDT) I'll gather the needed info and attach it here. Is
> it any specific info that you need, not sure if I have to go over attaching all
> as above anymore ? 
> 
> Another piece of info, I have added rd_NO_DM to the kernel line and it doesn't
> drop me to the shell anymore but it doesn't boot up all the way either. Looks
> like it calls for systemd and it says something about dependencies not met when
> fsck-ing the filesystems and then stays there w/o doing anything. Also, before
> systemd I need to hit a key to get the prompt for LUKS password.
> 
> Hope this helps, I'll come back w/ more info later today
> 
> Thanks,
> HC

either "rd_NO_DM" _or_ "rd_NO_MDIMSM"

Comment 9 hchickers 2011-08-23 14:04:57 UTC
Hi
I gave up and reinstalled w/o imsm (disabled RAID at the hardware/controller level and used software RAID) and so far it looks OK, boots up properly, even after I rebuilt the initramfs w/ the updated mdadm 3.2.2. 

You are probably right, from what research and tries I've done last night it seems that all is related to the mdadm that somehow lost imsm capabilities. I've tried installing the original version 3.1.5 and then a newer version found on FC16 testing repo w/ no success. Of course I have rebuilt the initramfs every time after playing around w/ the mdadm packages. After a few good hours of fiddling w/ it, since I needed the system up and running, I decided to rebuild as described above and, after little issues here and there (luks on the second md etc.) all seems to be working OK for now but I plan to do an upgrade as soon as FC16 is out.

Anyway, I believe that fc15 is not anywhere close to a finished/polished distro as 13 and 14 were and I am a little bit disappointed, are you guys dropping the bar a little @ Fedora. I've been a RH/Fedora user for over 15 years now and this is not one of the versions that I would recommend to anyone at this point. I hope you take no offence in my criticism here, I am trying to provide my feedback so things improve @ FC (still my distro of choice). 

Keep up the good work and thank you for the help on this. 

All the best,
HC

Comment 10 Fedora Admin XMLRPC Client 2011-10-20 16:20:17 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.