Bug 732371 - virt-manager's domain name is not correct if domain name has special character
Summary: virt-manager's domain name is not correct if domain name has special character
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 07:59 UTC by Huang Wenlong
Modified: 2013-10-20 21:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: virt-manager was not properly escaping reserved XML characters in domain names when showing them in the main vm list. Consequence: vm's with reserved XML characters in their name would not be shown correctly in the main vm list. Fix: Properly escape vm names Result: VM name's shown correctly in the main vm list
Clone Of:
Environment:
Last Closed: 2011-12-06 16:15:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description Huang Wenlong 2011-08-22 07:59:35 UTC
Description of problem:
virt-manager domain name is not correct in domain list ,if domain name has special character . 
if you double click domain name you will get the correct name on the top of the new window. 

Version-Release number of selected component (if applicable):
libvirt-0.9.4-2.el6.x86_64
virt-manager-0.9.0-5.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. create a domain xml name should be like following:
...
<name>ESX4.1-&lt;x86&gt;;1#1-2</name>
...

save xml as test.xml
2. #virsh create test.xml
3. virsh list
   Id Name State
----------------------------------
50 ESX4.1-<x86>;1#1-2 running

4. virt-manager

correct name is "ESX4.1-<x86>;1#1-2"
  
Actual results:
when mouse pass the domain name ,it will change . 


Expected results:
show correct name in domain list 

Additional info:
domain's operation windows of virt-manager can show the correct name of domain , so domain list also should show the correct domain name

Comment 3 Cole Robinson 2011-08-30 19:38:51 UTC
Fixed in virt-manager-0.9.0-6.el6

Comment 5 min zhan 2011-09-01 03:06:39 UTC
Verified PASS with below environment:
# uname -r
2.6.32-191.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
libvirt-0.9.4-6.el6.x86_64
virt-manager-0.9.0-6.el6.x86_64
python-virtinst-0.600.0-3.el6.noarch

Steps:
1. Prepare a guest xml
# cat guest.xml
...
<name>ESX4.1-&lt;x86&gt;;1#1-2</name>
...
2. # virsh create guest.xml
3. # virsh list
   Id Name State
----------------------------------
50 ESX4.1-<x86>;1#1-2 running

4. Launch virt-manager, this guest name can be displayed correctly in VMM window, Basic details and guest window title.


-----------
I can reproduce this bug with virt-manager-0.9.0-5.el6.x86_64.

Comment 6 Cole Robinson 2011-11-07 17:36:15 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
virt-manager was not properly escaping reserved XML characters in domain names when showing them in the main vm list.

Consequence:
vm's with reserved XML characters in their name would not be shown correctly in the main vm list.

Fix:
Properly escape vm names

Result:
VM name's shown correctly in the main vm list

Comment 7 errata-xmlrpc 2011-12-06 16:15:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.