Bug 732387 - ProgrammingError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.
Summary: ProgrammingError: You must not use 8-bit bytestrings unless you use a text_fa...
Keywords:
Status: CLOSED DUPLICATE of bug 730365
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.2
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard: abrt_hash:c2e5dfb9750dfe428013136f886...
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-22 09:25 UTC by Ľuboš Kardoš
Modified: 2016-08-01 01:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 16:29:49 UTC


Attachments (Terms of Use)
File: anaconda-tb-NDnNla (867.31 KB, application/octet-stream)
2011-08-22 09:30 UTC, Ľuboš Kardoš
no flags Details

Description Ľuboš Kardoš 2011-08-22 09:25:22 UTC
abrt version: 2.0.5
executable:     /mnt/runtime/usr/bin/python
hashmarkername: anaconda
kernel:         2.6.32-191.el6.ppc64
product:        Red Hat Enterprise Linux
reason:         ProgrammingError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.
time:           Mon Aug 22 01:15:58 2011
version:        6.2

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.132 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.6/site-packages/yum/sqlutils.py", line 168, in executeSQLQmark
:    return cursor.execute(query, params)
:  File "/usr/lib/python2.6/site-packages/yum/history.py", line 1290, in _save_anydb_key
:    executeSQL(cur, sql, (pid, attr, val))
:  File "/usr/lib/python2.6/site-packages/yum/history.py", line 1308, in _save_rpmdb
:    self._save_anydb_key(ipkg, "rpm", attr, val)
:  File "/usr/lib/python2.6/site-packages/yum/history.py", line 1339, in sync_alldb
:    if not self._save_rpmdb(ipkg):
:  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1610, in verifyTransaction
:    self.history.sync_alldb(po)
:  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1531, in runTransaction
:    self.verifyTransaction(resultobject)
:  File "/usr/lib/anaconda/yuminstall.py", line 1087, in _run
:    self.runTransaction(cb=cb)
:  File "/usr/lib/anaconda/yuminstall.py", line 1069, in run
:    if self._run(instLog, cb, intf) == DISPATCH_BACK:
:  File "/usr/lib/anaconda/yuminstall.py", line 1849, in doInstall
:    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
:  File "/usr/lib/anaconda/backend.py", line 242, in doInstall
:    return anaconda.backend.doInstall(anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/gui.py", line 1390, in nextClicked
:    self.anaconda.dispatch.gotoNext()
:  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib/anaconda/gui.py", line 1411, in handleRenderCallback
:    self.currentWindow.renderCallback()
:ProgrammingError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.

Comment 1 Ľuboš Kardoš 2011-08-22 09:30:00 UTC
Created attachment 519250 [details]
File: anaconda-tb-NDnNla

Comment 2 James Antill 2011-08-22 16:29:49 UTC

*** This bug has been marked as a duplicate of bug 730365 ***


Note You need to log in before you can comment on or make changes to this bug.