Bug 73239 - Kudzu segfaults when told to remove configuration for sharp zaurus
Summary: Kudzu segfaults when told to remove configuration for sharp zaurus
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 15:19 UTC by Need Real Name
Modified: 2014-03-17 02:30 UTC (History)
2 users (show)

Fixed In Version: 1.2.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 19:20:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-09-01 15:19:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Kudzu segfaults when told to remove configuration for sharp zaurus

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Remove zaurus that had been previoiusly found by kudzu from cradle
2.Run kudzu
3.Hit enter at the Kudzu intro screen
4.Select Remove Configuration
5.Kudzu Segfaults
	

Actual Results:  Kudzu segfaulted

Expected Results:  Kudzu should have removed the configuration for the sharp
zaurus (which didn't work anyways)

Additional info:

The problem also occurs during the boot process if I hit a key at the kudzu prompt.

I have screen captures of the problem, if they would be helpful.

Comment 1 Bill Nottingham 2002-09-02 04:41:52 UTC
Actually, a gdb traceback would be better.

Comment 2 Paul Hirst 2002-11-30 23:14:52 UTC
A gdb backtrace using the kudzu from redhat 8.0

#0  0x4207a4f3 in strlen () from /lib/i686/libc.so.6
#1  0x08052a1d in getAlias ()
#2  0x08052b46 in isAliased ()
#3  0x0804da04 in unconfigure ()
#4  0x0804ef5e in configMenu ()
#5  0x0804fc65 in main ()
#6  0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

This problem doesn't seem to be new to redhat 8.0. The same problem was occuring
in redhat 7.3.

Comment 3 Bill Nottingham 2005-09-23 19:20:13 UTC
This is presumably due to dev->driver and/or dev->device not being set.

This should be fixed in current rawhide kudzu.


Note You need to log in before you can comment on or make changes to this bug.