Bug 732397 - make .spec of balsa RHEL-compatible
Summary: make .spec of balsa RHEL-compatible
Keywords:
Status: ASSIGNED
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: balsa
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pawel Salek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 10:04 UTC by David Jaša
Modified: 2011-09-15 17:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description David Jaša 2011-08-22 10:04:44 UTC
Description of problem:
first line of balsa.spec file contains:
%define config_opts (some opts) --with-gmime=2.4 (other opts)
and then in BuildRequires:
BuildRequires: gmime-devel >= 2.5.1

RHEL 6 contains gmime 2.4.x so there should be added condition that for .el6 builds, '--with-gmime=2.4' and 'BuildRequires: gmime-devel >= 2.4' should be used

Version-Release number of selected component (if applicable):
balsa-2.4.9-6

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Pawel Salek 2011-09-06 20:28:56 UTC
I am not sure if I understand fully the report. el6 branch uses balsa-2.4.7 not 2.4.9, as far as I can tell. Can you please specify which exactly branch do you want to have patched, and preferably provide patch if you can list the changes specifically. Thank you.

Comment 2 David Jaša 2011-09-13 07:59:00 UTC
(In reply to comment #1)
> I am not sure if I understand fully the report. el6 branch uses balsa-2.4.7 not
> 2.4.9, as far as I can tell. Can you please specify which exactly branch do you
> want to have patched,

Because the package for .el6 isn't built, I've grabbed latest .src.rpm and tried to rebuild it.

> and preferably provide patch if you can list the changes
> specifically. Thank you.

I'll only outline it here because I don't have detailed knowledge of RPM packaging (this just mimicks wireshark.spec):

=========

%if 0%{?fedora} == 0
%define gmime_ver 2.6
%else
%define gmime_ver 2.4
%endif

%define config_opts (...) --with-gmime=%{gmime_ver} (...)

(...)

BuildRequires: gmime-devel >= %{gmime_ver} 

(Assuming that 2.5 is no longer used in any active branch, otherwise another %if-%else-%endif would have to be used.)

Comment 3 David Jaša 2011-09-13 08:03:53 UTC
(In reply to comment #2)
> %if 0%{?fedora} == 0
> %define gmime_ver 2.6
> %else
> %define gmime_ver 2.4
> %endif
> 

The versions should be vice versa (2.4 in %if and 2.6 in %else)

Comment 4 Pawel Salek 2011-09-15 06:07:24 UTC
I rather have branched version of spec file. Please check out the updated one. It builds fine with fedpkg mockbuild.

Comment 5 David Jaša 2011-09-15 12:40:27 UTC
(In reply to comment #4)
> I rather have branched version of spec file. Please check out the updated one.
> It builds fine with fedpkg mockbuild.

Where can I get the updated one? I can't find in in koji, git etc.

Comment 6 Pawel Salek 2011-09-15 17:40:09 UTC
You should be able to find in git. I see it there.
$ fedpkg co balsa
Cloning into balsa...
remote: Counting objects: 527, done.
remote: Compressing objects: 100% (319/319), done.
remote: Total 527 (delta 176), reused 484 (delta 161)
Receiving objects: 100% (527/527), 94.47 KiB | 81 KiB/s, done.
Resolving deltas: 100% (176/176), done.
$ cd balsa
$ fedpkg switch-branch el6


Note You need to log in before you can comment on or make changes to this bug.