Bug 73240 - Mishandling of border css property?
Summary: Mishandling of border css property?
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 15:28 UTC by Owen Taylor
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 11:24:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HTML page demonstrating problem (315 bytes, text/html)
2002-09-01 15:29 UTC, Owen Taylor
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 206631 None None None Never

Description Owen Taylor 2002-09-01 15:28:07 UTC
The attached (very short) html page renders with a 2 pixel border
on 3 sides, and 1 pixel border on the 4th, instead of a 1 pixel
border all the way around as expected.

Filing here because I don't know the relationship of our releases
to official upstream releases.

$ rpm -q mozilla
mozilla-1.0.1-24

(The bug was said to occur for "mozilla-1.0.0-5.ximian.1" as well,
but not for "mozilla-1.0.0-0_xft", which makes little sense to 
me.)

Comment 1 Owen Taylor 2002-09-01 15:29:01 UTC
Created attachment 74424 [details]
HTML page demonstrating problem

Comment 2 Christopher Blizzard 2002-09-01 16:20:35 UTC
I wonder if this is a rounding error of some kind.  In the DOM inspector I see:

border-bottom-width: 1.42857px.

My first nieve guess would be that this is a rounding error.  If the ximian
folks are blindly using keith's patch, which they might be, it computes DPI
using a different method which would account for the difference.

Comment 3 Christopher Aillon 2005-03-31 11:24:45 UTC
https://bugzilla.mozilla.org/show_bug.cgi?id=206631


Note You need to log in before you can comment on or make changes to this bug.