Bug 732422 - emacs doesn't start without font installed
Summary: emacs doesn't start without font installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Karel Klíč
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 12:25 UTC by Martí­n Marqués
Modified: 2013-03-03 23:03 UTC (History)
3 users (show)

Fixed In Version: emacs-23.3-9.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 16:03:31 UTC


Attachments (Terms of Use)

Description Martí­n Marqués 2011-08-22 12:25:54 UTC
Description of problem:

With a default F15 instalation, one can install emacs and not xorg-x11-fonts-misc, which with the default emacs font configuration will exit (not start) with error:

$ emacs
Font `8x13' is not defined

No .emacs of .Xdefaults in user directory.

Version-Release number of selected component (if applicable):


$ rpm -q emacs
emacs-23.2-19.fc15.x86_64

$ rpm -q xorg-x11-fonts-misc
xorg-x11-fonts-misc-7.5-4.fc15.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Karel Klíč 2011-09-27 10:05:34 UTC
Thank you. I added the dependency to the rawhide package for now. It might be backported to older releases with some more important changes later.

Comment 2 Jens Petersen 2012-01-29 09:56:46 UTC
I am not sure if this is really still needed?
In fact the change only seems to be in rawhide where it is least needed? :)

I suspect the bitmap font is not required for emacs >= 23.3 ?

Rawhide emacs-24 seems to run just fine without xorg-x11-fonts-misc anyway.
I think the same is true for F16 and probably also F15.

Comment 3 Jens Petersen 2012-02-06 05:13:50 UTC
I tried the original F15 emacs-23.2 package and current 23.3 package but
didn't see the font warning.

Any more details on how to reproduce this?

I note though that xorg-x11-fonts-misc is larger than emacs itself
so this is not such a light dependency.

Comment 4 Jens Petersen 2012-02-29 01:58:15 UTC
I moved the to F17 since that is where the change is applied.

Do you think the change can be reverted or is it really needed?

Comment 5 Jens Petersen 2012-06-07 09:41:16 UTC
Ping?

Still no response to this.

Could there please be some explanation when this large font
has to be installed by default, otherwise can we please drop
this large redundant dependency? :-)

Thanks

Comment 6 Karel Klíč 2012-06-07 11:53:50 UTC
Jens, thank you for the ping.  AFAICT this bug happens when you go from minimal install, and install emacs + Xorg server + some minimal window manager such as Xmonad.  In this case, no reasonable fonts get installed and emacs exists with an error.

It also happened to me some time ago.  I agree that we should reproduce this issue in F17.

Maybe there is a better way of fixing this via some virtual dependency?

Comment 7 Jens Petersen 2012-07-17 08:21:10 UTC
Ah I see - thanks for the explanation.

Hmm for that case I am not sure what to suggest,
though it is kind of a corner case.
What font does emacs use by default for a normal
Live or Desktop install say?

Anyway we are trying to deprecate bitmap fonts in Fedora,
so this change is kind of going against that flow.
I think people starting from a minimal install are pretty much
on their own and need to pickup their own fonts probably
- through I agree things could be made better.

Perhaps a @minimal-desktop group would be good?

Comment 8 Jens Petersen 2012-08-27 09:33:17 UTC
I think it would be better at least to require dejavu-sans-mono-fonts instead.
Depending on a (bitmap) font that is not installed by default in Fedora
(ie not listed in the @fonts group) seems unacceptable to me.

Comment 9 Jens Petersen 2012-10-21 12:56:08 UTC
Ping!

Further if one looks in the font chooser dialog you can
see than no bitmaps are listed to choose from.

So can you please change the Requires from xorg-x11-fonts-misc
to dejavu-sans-mono-fonts which seems to be the default still
in F18 too.

Comment 10 Jens Petersen 2012-10-22 06:00:00 UTC
I did a test now on a minimal F18 install, where I installed @base-x,
xterm and emacs.  Note that emacs' ImageMagick dep already pulls in
ghostscript-fonts and urw-fonts - so that Emacs uses Nimbus Mono L
(together with Nimbus Sans L for its chrome), so there really is no
reason to install xorg-x11-fonts-misc.  I think Emacs buffers look
much better with dejavu Mono than Nimbus though so I still recommend
changing the requires to dejavu-sans-mono-fonts.

I really wish the redundant dep can be fixed finally in time for F18.
If you don't have time then I am happy to do that. :)
It would be nice to backport it also to F17.

Comment 11 Karel Klíč 2012-10-22 10:02:51 UTC
Jens, thank you for the test!  I'm changing the dependency to dejavu-sans-mono-fonts.

Comment 12 Fedora Update System 2012-10-22 15:57:22 UTC
emacs-24.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/emacs-24.1-6.fc17

Comment 13 Fedora Update System 2012-10-22 15:57:32 UTC
emacs-24.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/emacs-24.2-4.fc18

Comment 14 Fedora Update System 2012-10-23 01:56:58 UTC
Package emacs-24.1-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.1-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16677/emacs-24.1-6.fc17
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2012-12-20 16:03:35 UTC
emacs-24.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.