Bug 732424 - Kmod-wl not updating together with kernel update.
Summary: Kmod-wl not updating together with kernel update.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 12:40 UTC by Miguel Angelo Mello
Modified: 2014-01-21 23:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 16:08:06 UTC


Attachments (Terms of Use)

Description Miguel Angelo Mello 2011-08-22 12:40:04 UTC
Description of problem: 
The problem is kmod-wl update not being done together with kernel update.

Version-Release number of selected component (if applicable): 
All

How reproducible:
When doing a kernel update via yum, the kmod-wl not being updated together with kernel because it is not available in the yum repos yet. 

Steps to Reproduce:
1. Yum update
2.
3.
  
Actual results:
System boots with the updated kernel, but kmod-wl not. To solve the problem, you are forced to boot with the old kernel for some days, so the kmod-wl to load properly. You must track manually the yum repos till the properly kmod-wl version is shown, when then you can install it. 

Expected results:
When doing a kernel update, the kmod-wl version for the kernel should already be avaivable in the you repos, so they are installed together. 

Additional info:
For advanced Fedora Users like me, this problem is not big deal, but for beginners and intermediary users, this problem may render their wireless connection off forever, since they may not figure out they can keep tracking the yum repos for the properly kmod-wl version, and then, install it. They may be forced to think there is a problem with Fedora Wireless Subsystem, where actually there is not.

Comment 1 Tim Lauridsen 2011-08-22 16:07:49 UTC
kmod-wl is not a fedora package and is available from a 3 part repo (rpmfusion), so there will be some kind of delay before rpmfusion can build new version, when a kernel is released in fedora. There is nothing we can do about this.
The main issue is that broadcom dont have a working driver for all chipsets in the upstream kernel, so you need a binary driver (wl) to get your broadcom wifi working.

You can install the akmod-wl package from rpmfusion, it will automatic build and install a kmod-wl package for a new kernel, so your not have to care about missing kmod-wl from rpmfusion.

Comment 2 Miguel Angelo Mello 2011-08-22 18:54:00 UTC
Tim,

Thank you for the plain text explanation. I have understood everything. However, I guess this explanation could be present somewhere in the Fedora Documentation regarding wireless setup. I have searched the documentation for that, but nothing found. Regards.


Note You need to log in before you can comment on or make changes to this bug.