Bug 732437 - mailx produces error msg about mailbox locking
Summary: mailx produces error msg about mailbox locking
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mailx
Version: 15
Hardware: i686
OS: Mac OS
unspecified
medium
Target Milestone: ---
Assignee: Peter Schiffer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 13:15 UTC by Art Werschulz
Modified: 2012-06-19 14:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-19 14:44:18 UTC


Attachments (Terms of Use)

Description Art Werschulz 2011-08-22 13:15:59 UTC
Description of problem:
When entering "mail" at the shell's command-line prompt, I get an error msg
  Unable to lock mailbox: Input/output error
and an exit status of 1.

Version-Release number of selected component (if applicable):
mailx-12.5-3.fc15.i686

How reproducible:
Type the "mail" or "mailx" command at the shell's command-line prompt.

Steps to Reproduce:
1. Type the "mail" or "mailx" command.
2.
3.
  
Actual results:
An error msg
  Unable to lock mailbox: Input/output error
and an exit status of 1.

Expected results:
The usual list of mail msgs, or a msg "No mail for joeuser"

Additional info:
We are NFS-mounting a mail spool directory.
The problem does not occur when running the "mail" command directly on the machine containing this directory.  The problem only occurs on machines that are NFS-mounting the mail spool directory.
This problem did not occur with previous versions of Fedora; it only occurred when we upgraded from Fedora 14 to Fedora 15.

Comment 1 Marcus Hall 2011-09-25 20:55:49 UTC
Also seeing the same issue with a fedora 15 server and client.  I no longer seem to be able to use the "nolock" option to NFS, which may be what is causing this issue??  I can specify "nolock" as an option to the mount, but it seems to not be honored, since it doesn't show up in the options running "mount" after the filesystem is mounted.

Comment 2 Peter Schiffer 2012-05-30 14:36:18 UTC
Hello guys,

please, do you still see this issue? I've try to reproduce it, but with no luck:

$ rpm -q mailx
mailx-12.5-3.fc15.x86_64

$ mount | grep spool
10.34.4.205:/var/spool on /var/spool type nfs4 (rw,relatime,vers=4,rsize=65536,wsize=65536,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.34.4.247,minorversion=0,local_lock=none,addr=10.34.4.205)

$ mailx
No mail for joe

Comment 3 Art Werschulz 2012-06-19 14:33:32 UTC
The problem seems to have gone away in Fedora 16.

Comment 4 Peter Schiffer 2012-06-19 14:44:18 UTC
Thank you Art. Closing this as NEXTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.