Bug 732441 - anaconda uses metadata version 0.9 for mdraided /boot
anaconda uses metadata version 0.9 for mdraided /boot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-08-22 09:35 EDT by Rudolf Kastl
Modified: 2011-08-22 15:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-22 15:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program log (407.58 KB, text/x-log)
2011-08-22 14:10 EDT, Rudolf Kastl
no flags Details

  None (edit)
Description Rudolf Kastl 2011-08-22 09:35:10 EDT
Description of problem:
anaconda uses metadata version 0.9 for mdraided /boot instead of 1.2 because of an old limitation of grub1 not beeing able to boot from metadata versions > 0.9. I have verified that this is not the case for grub2 anymore.

Version-Release number of selected component (if applicable):
f16 alpha rc5

How reproducible:
always

Steps to Reproduce:
1. create an mdraided /boot with raidlevel 1 in anaconda
2. check the metadata version given in the superblock infos
3. see that /boot uses 0.9 whereas all other raidsets get 1.2
Comment 1 David Lehman 2011-08-22 12:03:14 EDT
Please attach /var/log/anaconda/anaconda.program.log from the system so I can see what exactly was done. Thanks.
Comment 2 Rudolf Kastl 2011-08-22 14:10:51 EDT
Created attachment 519324 [details]
program log

program log
Comment 3 Rudolf Kastl 2011-08-22 14:12:28 EDT
mdadm is executed with 1.0 metadata flag... after reboot it did show me 0.9 as version for md0 though as far as i recall. the default version is 1.2. it works for grub2 if grub 1.99 final is beeing used.
Comment 4 David Lehman 2011-08-22 15:18:30 EDT
02:23:39,609 INFO program: Running... mdadm --create /dev/md0 --run --level=1 --raid-devices=2 --metadata=1.0 /dev/sda2 /dev/sdb2
02:23:39,893 ERR program: mdadm: array /dev/md0 started.

We are creating the array with --metadata=1.0. If mdadm is somehow overriding that it is definitely an mdadm bug. It should not be overriding explicitly specified parameters.

Note You need to log in before you can comment on or make changes to this bug.