Bug 732498 - Data addresses populated with class name
Data addresses populated with class name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Russell Bryant
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-22 12:55 EDT by Dave Johnson
Modified: 2011-12-06 06:40 EST (History)
3 users (show)

See Also:
Fixed In Version: matahari-0.4.2-8.el6
Doc Type: Bug Fix
Doc Text:
Cause: The data address for Matahari QMF objects was inconsistent. Consequence: With some agents, the data address was the class name. In others, it was a UUID. Change: Matahari has been updated to consistently use the class name as the data address. Result: The data address across Matahari agents is now consistent.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 06:40:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2011-08-22 12:55:41 EDT
Description of problem:
===================================
With a matahari host (or network) agent connected to a broker, if I query the matahari agent class with qmf-tool, I get a list of objects with their associated data address like:

    Data Objects Returned: 1:
        Number  Data Address
        --------------------------------------------
        5       0da188af-2882-411d-84bd-c03001a5caba

However, when querying the matahari Services/Resources/Sysconfig classes, the data address is the class name.  Is that right?

    Data Objects Returned: 1:
        Number  Data Address
        ------------------------
        4       sysconfig

    Data Objects Returned: 1:
        Number  Data Address
        ------------------------
        3       Services

    Data Objects Returned: 1:
        Number  Data Address
        ------------------------
        2       Resources


Version-Release number of selected component (if applicable):
======================================================================
v0.4.2-7

How reproducible:
===================================
100%

Steps to Reproduce:
===================================
1.  install/start local matahari broker and agents
Repeat for each matahari agent
2.  set the agent as default
3.  query the class
4.  notice the data address
Comment 2 Russell Bryant 2011-08-22 19:32:49 EDT
Upstream patch committed:

https://github.com/matahari/matahari/commit/a67ab9c27873bb552222bbf1d8a0100872d3e456
Comment 4 Dave Johnson 2011-08-24 15:40:02 EDT
Good 2 go in v0.4.2-9, all agents now use the following format

    Data Objects Returned: 1:
        Number  Data Address
        ------------------------
        2       <class-name>
Comment 5 Russell Bryant 2011-11-16 16:48:10 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: The data address for Matahari QMF objects was inconsistent.
Consequence: With some agents, the data address was the class name.  In others, it was a UUID.
Change: Matahari has been updated to consistently use the class name as the data address.
Result: The data address across Matahari agents is now consistent.
Comment 6 errata-xmlrpc 2011-12-06 06:40:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html

Note You need to log in before you can comment on or make changes to this bug.