Bug 732508 - Significant decrease in nouveau performance between kernels 3.0.1 and 3.1-rc2
Summary: Significant decrease in nouveau performance between kernels 3.0.1 and 3.1-rc2
Keywords:
Status: CLOSED DUPLICATE of bug 735268
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 16
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 18:15 UTC by Adam Williamson
Modified: 2011-09-10 00:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-10 00:07:44 UTC


Attachments (Terms of Use)
X log from 3.1-rc2 (57.07 KB, text/plain)
2011-08-22 18:21 UTC, Adam Williamson
no flags Details
/var/log/messages from 3.1-rc2 (108.43 KB, text/plain)
2011-08-22 18:22 UTC, Adam Williamson
no flags Details
X log from 3.0.1 (57.06 KB, text/plain)
2011-08-22 18:27 UTC, Adam Williamson
no flags Details
/var/log/messages from 3.0.1 (100.45 KB, text/plain)
2011-08-22 18:28 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2011-08-22 18:15:57 UTC
There's a significant decrease in the performance of nouveau in kernel-3.1.0-0.rc2.git7.2.fc16.x86_64 compared to kernel-3.0.1-3.fc16.x86_64 (the previous update) for me. All graphics operations are observably sluggish with the new kernel, and this is confirmed with a simple gtkperf benchmark. gtkperf has various issues, but it's sufficient to demonstrate the issue: with 3.0.1-3 gtkperf runs in 6.40 seconds, with 3.1-rc2 it takes 27.41. there's obviously a major issue there.

Will attach logs and so forth.

Comment 1 Adam Williamson 2011-08-22 18:21:56 UTC
Created attachment 519326 [details]
X log from 3.1-rc2

Comment 2 Adam Williamson 2011-08-22 18:22:21 UTC
Created attachment 519327 [details]
/var/log/messages from 3.1-rc2

Comment 3 Adam Williamson 2011-08-22 18:27:08 UTC
Created attachment 519328 [details]
X log from 3.0.1

Comment 4 Adam Williamson 2011-08-22 18:28:25 UTC
Created attachment 519329 [details]
/var/log/messages from 3.0.1

Comment 5 Adam Williamson 2011-08-22 23:31:44 UTC
Note that Ben thinks this may not be a nouveau-specific issue, so if anyone's seeing this with some other graphics driver, please speak up: that'd be useful info. thanks!

Comment 6 Adam Williamson 2011-08-23 00:03:46 UTC
kernel rc3 does seem somewhat faster:

Total time: 10.88

so a lot faster than rc2, but still slower than rc1 (though may be within the bounds of gtkperf's crappiness). Things certainly seem slicker than rc2 subjectively as well, I'd like to say they still feel a _little_ slow but it may be just confirmation bias...

Comment 7 Adam Williamson 2011-08-23 00:50:20 UTC
there seems a fairly nice correlation between CPU usage of X process, perceived speed, and measured speed across the three kernels...

so I tested just by running htop on one monitor, firefox on the other, and loading bluesnews.com and hardocp.com and scrolling through them a few times. fairly rough and ready test, I know.

on 3.0.1-3, which feels and measures the fastest, CPU usage doesn't get past 20% doing those operations multiple times.

on 3.1-rc3, which feels and measures in the middle, it spikes to 35% and gets over 20% quite a bit.

on 3.1-rc2, which feels and measures slowest, it spikes at over 50% and is over 30% the whole time while scrolling.

I don't see anything in /var/log/messages while doing these tests on any kernel, even with drm.debug=15.

Comment 8 Adam Williamson 2011-09-10 00:07:44 UTC

*** This bug has been marked as a duplicate of bug 735268 ***


Note You need to log in before you can comment on or make changes to this bug.