Bug 73251 - The replies Y/N/C in functions are marked for translation but not extracted
Summary: The replies Y/N/C in functions are marked for translation but not extracted
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 20:10 UTC by Göran Uddeborg
Modified: 2014-03-17 02:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 05:55:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Göran Uddeborg 2002-09-01 20:10:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
The possible replies to the question in "confirm()" at the end of functions are
marked for translation with $"..." but are not found in the po file.

Version-Release number of selected component (if applicable): 6.90-1


How reproducible:
Always

Steps to Reproduce:
1.Inspecting any po file shows this.

	

Additional info:

The reason seems to be that the script used to extract these strings,
po/xgettext_sh.py searches for the string ` $"', i.e. a space preceeding
dollar-quote.  But the reply strings are not preceeded by space.

Comment 1 Bill Nottingham 2003-01-14 05:55:53 UTC
Fixed in xgettext_sh.py. more strings will show up in the next pull


Note You need to log in before you can comment on or make changes to this bug.