Bug 73253 - Memory leak in rhn-applet-gui
Memory leak in rhn-applet-gui
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rhn-applet (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-01 16:37 EDT by Tim Clymo
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 16:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2002-09-01 16:37:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
It leaks memory - tried 2.0.0-10 and 2.0.0-14

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run /usr/bin/rhn-applet-gui& from a terminal (assuming it isn't already running)
2.repeated "ps -l" and observe rhn-applet-gui size in field #10 growing
3.give it long enough to get really big, and the system runs out of memory and
starts to swap - eventually, it grinds to a halt
	

Actual Results:  System eventually ran out of memory

Expected Results:  rhn-applet-gui should sit inoffensively in the backgroung
doing its stuff

Additional info:
Comment 1 Chip Turner 2002-09-01 18:01:52 EDT
this was a leak in the gdkpixbuf bindings, and has since been fixed in the
latest trees.

Note You need to log in before you can comment on or make changes to this bug.