This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 732531 - RFE: LVM RAID - Support RAID1 merge of LVs split from array with change tracking
RFE: LVM RAID - Support RAID1 merge of LVs split from array with change tracking
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jonathan Earl Brassow
Corey Marthaler
: FutureFeature
Depends On:
Blocks: 749672 756082
  Show dependency treegraph
 
Reported: 2011-08-22 15:55 EDT by Jonathan Earl Brassow
Modified: 2012-06-20 10:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: lvm2-2.02.95-1.el6
Doc Type: Enhancement
Doc Text:
New Feature to 6.3. No documentation required. Bug 732458 is the bug that requires a release note for the RAID features. Other documentation is found in the LVM manual. Operational bugs need no documentation because they are being fixed before their initial release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2011-08-22 15:55:01 EDT
LVs that are split from a RAID1 array with '--trackchanges' should be able to be merged back into the array from which they came.  Only those portions of the array which changed since the split should be resync'ed.
Comment 1 Jonathan Earl Brassow 2011-08-22 16:04:41 EDT
Command synopsis:
example~> lvconvert --merge vg/lv_rimage_2

Release criteria (test requirements):
- Merge should be successful
- Image should be resync'ed
- No data corruption (stale data from image should not be accessible regardless of which image was split and then merged)
- There should be /some/ way of detecting when an image has finished its resync (either via dmsetup or some LVM command (e.g. 'lvs'))
Comment 2 Corey Marthaler 2011-08-31 14:42:35 EDT
Adding QA ack for 6.3.

Devel will need to provide unit testing results however before this bug can be
ultimately verified by QA.
Comment 4 Jonathan Earl Brassow 2011-11-30 19:26:33 EST
Unit test verification:

[root@bp-01 ~]# lvconvert --splitmirrors 1 --trackchanges vg/lv
  lv_rimage_1 split from lv for read-only purposes.
  Use 'lvconvert --merge vg/lv_rimage_1' to merge back into lv
[root@bp-01 ~]# devices vg
  LV            Copy%  Devices                      
  lv            100.00 lv_rimage_0(0),lv_rimage_1(0)
  [lv_rimage_0]        /dev/sdc1(1)                 
  lv_rimage_1          /dev/sdd1(1)                 
  [lv_rmeta_0]         /dev/sdc1(0)                 
  [lv_rmeta_1]         /dev/sdd1(0)                 
[root@bp-01 ~]# lvconvert --merge vg/lv_rimage_1
  vg/lv_rimage_1 successfully merged back into vg/lv
[root@bp-01 ~]# devices vg
  LV            Copy%  Devices                      
  lv            100.00 lv_rimage_0(0),lv_rimage_1(0)
  [lv_rimage_0]        /dev/sdc1(1)                 
  [lv_rimage_1]        /dev/sdd1(1)                 
  [lv_rmeta_0]         /dev/sdc1(0)                 
  [lv_rmeta_1]         /dev/sdd1(0)
Comment 5 Jonathan Earl Brassow 2011-11-30 19:27:24 EST
Feature present in LVM2 version 2.02.89
Comment 8 Jonathan Earl Brassow 2012-04-23 14:19:25 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
New Feature to 6.3.  No documentation required.

Bug 732458 is the bug that requires a release note for the RAID features.  Other documentation is found in the LVM manual.

Operational bugs need no documentation because they are being fixed before their initial release.
Comment 9 Corey Marthaler 2012-05-02 19:43:05 EDT
Feature verified in the latest kernel.

2.6.32-269.el6.x86_64
lvm2-2.02.95-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
lvm2-libs-2.02.95-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
lvm2-cluster-2.02.95-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
device-mapper-libs-1.02.74-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
device-mapper-event-1.02.74-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
device-mapper-event-libs-1.02.74-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
cmirror-2.02.95-7.el6    BUILT: Wed May  2 05:14:03 CDT 2012
Comment 11 errata-xmlrpc 2012-06-20 10:59:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Note You need to log in before you can comment on or make changes to this bug.