Bug 732536 - Very strange "mount" output with same mount points listed twice or more
Summary: Very strange "mount" output with same mount points listed twice or more
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 20:12 UTC by Nikolai Maziashvili
Modified: 2011-08-29 16:28 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 12:06:09 UTC


Attachments (Terms of Use)
Output of mount command (3.09 KB, text/plain)
2011-08-22 20:12 UTC, Nikolai Maziashvili
no flags Details
Output of /proc/mounts (2.91 KB, text/plain)
2011-08-22 20:27 UTC, Nikolai Maziashvili
no flags Details
output of a /proc/self/mountinfo (3.39 KB, text/plain)
2011-08-22 21:23 UTC, Nikolai Maziashvili
no flags Details
Output of mount command after sanbox is set to off (2.63 KB, application/octet-stream)
2011-08-26 14:01 UTC, Nikolai Maziashvili
no flags Details

Description Nikolai Maziashvili 2011-08-22 20:12:48 UTC
Created attachment 519343 [details]
Output of mount command

Description of problem:

I get very strange output of a "mount" command. For example if i trust this output then my /tmp should be mounted twice, partition that supposed to be mounted as root is mounted under "/" and under "/var/tmp" at the same time.
Very disturbing picture, while system works just fine, i'm glad that this is just my laptop and not production machine, otherwise i would literally freak out.

I have folowing set up:
2 SSDs + 1HDD.

Only physical partition is /dev/sda1 on SSD mounted as /boot.
Rest of SSDs is one physical volume for LVM.
    Here i have few logical volumes:
    /
    /tmp  (encrypted, enplanes luks mentioning in output)
    /home (encrypted, enplanes luks mentioning in output)
    Couple more LVs that are not mounted (only when needed)

HDD is physical volume for LVM as well.
     Couple of LVs, only one is mounted constantly 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
I can't even understand what in there

Expected results:
Just mount points (partitions) listed that are actually mounted

Additional info:
Please see attachment for "mount" output

Comment 1 Josh Boyer 2011-08-22 20:17:43 UTC
Can you paste the output of 'cat /proc/mounts' and tell us which version of util-linux you have installed?

Comment 2 Nikolai Maziashvili 2011-08-22 20:27:01 UTC
Created attachment 519347 [details]
Output of /proc/mounts

Comment 3 Nikolai Maziashvili 2011-08-22 20:29:27 UTC
And util-linux:
util-linux-2.19.1-1.4.fc15.x86_64

Comment 4 Josh Boyer 2011-08-22 20:46:05 UTC
OK, something actually mounted a variety of devices twice, so mount is just dutifully displaying what happened.  It doesn't really appear to be a kernel bug.  

I think systemd does this, but I can't recall what the reasons are exactly.  Hopefully Lennart can explain.

Comment 5 Kay Sievers 2011-08-22 20:58:24 UTC
Please attach the output of /proc/self/mountinfo. The old /proc/mounts doesn't
show what we need to know today.

Comment 6 Lennart Poettering 2011-08-22 21:04:30 UTC
You probably have the selinux sandbox installed, right? It creates a couple of bind mounts. Consider removing it and the bind mounts will go away...

Comment 7 Nikolai Maziashvili 2011-08-22 21:22:46 UTC
Hi Lennart,
I do not have sandbox installed (policycoreutils-sandbox - this what you mean right?). 
I have attached mountinfo output.

Comment 8 Nikolai Maziashvili 2011-08-22 21:23:26 UTC
Created attachment 519356 [details]
output of a /proc/self/mountinfo

Comment 9 Kay Sievers 2011-08-22 22:17:24 UTC
45 22 253:9 / /tmp rw,relatime
46 45 253:9 / /tmp rw,relatime

The second line looks like an additional bind mount on top of the first
one.

Having /tmp and /home duplicated might be related to selinux or
pam_namespace:
  https://bugzilla.redhat.com/show_bug.cgi?id=701176#c9
  https://bugzilla.redhat.com/show_bug.cgi?id=698793#c14

Comment 10 Harald Hoyer 2011-08-23 06:22:39 UTC
might be the "sandbox" service?

$ chkconfig --list sandbox

Comment 11 Nikolai Maziashvili 2011-08-26 13:49:43 UTC
Hi Harald,
sandbox was indeed "on" , which i thought was strange considering i do not have policycoreutils-sandbox installed on my machine. But anyway i turned it "off" but output of mount dos't look any better,

Comment 12 Nikolai Maziashvili 2011-08-26 13:58:54 UTC
Im so sorry that i can't edit my comments here, but i was to hasty to comment. When i closely examined output i realized that it WAS looking better then before, for example it didn't show me "/" being mounted twice. I'll upload attachment in a minute.

Comment 13 Nikolai Maziashvili 2011-08-26 14:01:20 UTC
Created attachment 520095 [details]
Output of mount command after sanbox is set to off

I have noticed that after setting sandbox to off (chkconfig sanbox off) i got mount output with one "/", one "/home" and one "/tmp" entries, which is nice.

Comment 14 Lennart Poettering 2011-08-29 12:06:09 UTC
rpm -qf /etc/rc.d/init.d/sandbox will tell you that sandbox is in "polycoreutils", not "policycoreutils-sandbox".

Closing, since this is expected behaviour and has little to do with systemd.

Comment 15 Nikolai Maziashvili 2011-08-29 12:45:17 UTC
Excuse me, What is expected behavior? Is installing F15 and getting from "mount" command that something very strange is going with your system can be considered as expected?
Or maybe you mean that is expected from me - a F15 user, to know that it SElinux (sandbox) can be the reason why system gives faulty information. And i should know that first thing i have to do is turn off sandbox daemon.
What is exactly expected behavior? And why bug is closed? Is problem solved? Or maybe turning of sandbox daemon is the solution to this problem. If yes, why it is installed and activated from the start?

Comment 16 Daniel Walsh 2011-08-29 16:20:44 UTC
The mount command is showing bind mounts.  Sandbox is used for pam_namespace and requires bind mounts to be setup.  pam_namepspace has been fixed to not require this any longer and will be fixed in F16.

Comment 17 Nikolai Maziashvili 2011-08-29 16:28:39 UTC
Thank you Daniel. This clears up for me.


Note You need to log in before you can comment on or make changes to this bug.