Bug 73255 - up2date-config disables "Use GPG ..." prematurely
Summary: up2date-config disables "Use GPG ..." prematurely
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-02 00:10 UTC by Jay Berkenbilt
Modified: 2015-01-08 00:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 01:10:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2002-09-02 00:10:15 UTC
Description of Problem:

In up2date-config, if you select "Do not install packages after retrieval", the
option to select or unselect "Use GPG to verify package integrity" is disabled
(as it is under the installation options area).  This is not appropriate as the
GPG option controls not only installation but also downloading.  These should be
able to be selected independently.  If you either modify the GPG option before
modifying the package retrieval option or manually edit
/etc/sysconfig/rhn/up2date, everything works properly with GPG turned off and do
not install after retrieval turned on.

Version-Release number of selected component (if applicable):

up2date-2.9.55-2

How Reproducible:

always

Steps to Reproduce:
1. up2date-config
2. check "Do not install packages after retrieval"

Actual Results:

The GPG check box is disabled

Expected Results:

It should not be

Additional Information:
	
I have disabled GPG checks for now because up2date crashes without it.  That's a
separate issue that I am reporting in a separate bug report.

Comment 1 Adrian Likins 2002-09-02 00:34:08 UTC
hmm, indeed.

Taking a look at it now...

Comment 2 Adrian Likins 2002-09-02 01:10:15 UTC
Should be fixed in 2.9.66.

the useGPG button has been moved to it's
own frame now "Package Verification" since it
applies both to downloaded packages and
packages going to be installed (say, pointed
at via --packagedir, hence not downloaded)


Comment 3 Jay Berkenbilt 2002-10-05 00:52:12 UTC
This is definitely fixed in 8.0.


Note You need to log in before you can comment on or make changes to this bug.