This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 73256 - up2date crashed with rpm error due to lack of GPG key on kernel
up2date crashed with rpm error due to lack of GPG key on kernel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-01 20:15 EDT by Jay Berkenbilt
Modified: 2015-01-07 19:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-11 07:33:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2002-09-01 20:15:32 EDT
Description of Problem:

When I ran up2date and told it to grab the new kernel, I got a dialog indicating
that the package was not signed and asking whether I should continue.  I clicked
"OK" and up2date crashed issuing an error message about an rpm error.

Sadly, I do not have the exact details anymore, and can no longer reproduce the
problem, so the above is the best I can do as far as specific details or error
messages.  But see below for some additional information.

Version-Release number of selected component (if applicable):

up2date 2.9.55-2


How Reproducible:

unknown

Steps to Reproduce:
1. install (null) from scratch
2. manually update to the following by downloading and installing:

libelf-0.8.2-2.i386.rpm
libelf-devel-0.8.2-2.i386.rpm
rpm-4.1-1.0.i386.rpm
rpm-build-4.1-1.0.i386.rpm
rpm-devel-4.1-1.0.i386.rpm
rpm-python-4.1-1.0.i386.rpm
up2date-2.9.55-2.i386.rpm
up2date-gnome-2.9.55-2.i386.rpm

3. run up2date

Actual Results:

observe behavior described in "Problem Description"; i.e., up2date crashes after
OK is selected on warning dialog about unsigned package

Expected Results:

It should have continued downloading

Additional Information:
	
I worked around this by turning off use of GPG.  Now my system is up to date, so
I can no longer reproduce the problem.
Comment 1 Adrian Likins 2002-09-01 20:37:23 EDT
I think this was a combo of a weird rpm bug, a glibc bug, and
up2date not handling the exception it got.

It seems to work fine with current code bases of rpm/up2date
(slightly newer versions of up2date/rpm than you list)
2.9.64 for up2date and I belive rpm-4.1-1.04

I'm setting this to modified since it seems to work
for me in the current code base, and sounds like a
bug thats known fixed.
Comment 2 Jay Berkenbilt 2003-02-10 23:07:24 EST
This does seem to be fixed.... any reason why it's still open?
Comment 3 Jay Turner 2003-02-11 07:33:51 EST
Closing out based on feedback from the original poster.

Note You need to log in before you can comment on or make changes to this bug.