Bug 732573 - multiple xfdesktop processes spawned on login consuming many memory
Summary: multiple xfdesktop processes spawned on login consuming many memory
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xfdesktop
Version: 15
Hardware: i386
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 00:30 UTC by Ataliba Teixeira
Modified: 2012-08-07 19:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 19:55:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 5123 None None None Never

Description Ataliba Teixeira 2011-08-23 00:30:17 UTC
Description of problem:

My login is very slow, because xfdesktop using many of my memory and put my processor use on 99% . 

Version-Release number of selected component (if applicable): xfdesktop-4.8.2-1.fc15.i686

How reproducible:

I had this problem on my logins on xfce4 on Fedora 14 and Fedora 15.


Additional info:

When logging into an xfce session, multiple xfdesktop proccess are spawned. 
At this momento, I had 135 proccess on my computer. 
To solve this problem, last time, I need to clear the config of ~/.config/xfce4.

Comment 1 Ataliba Teixeira 2011-08-23 00:31:03 UTC
I see an bug on Ubuntu, like my problem. 

https://bugs.launchpad.net/ubuntu/+source/xfdesktop4/+bug/335441

Comment 2 Kevin Fenzi 2011-08-23 03:35:57 UTC
This is upstream bug 5123. It's not shown up in a while... ;( I had hoped it was solved. 

Was this machine an upgrade? Or a clean install? 

Can you get the duplicate entries to appear again? Or was it a one time issue?

Comment 3 Ataliba Teixeira 2011-08-23 12:56:19 UTC
Hello,

this is a clean install. When I try to update my Fedora to the new version ( 15 ), I had some problems. But my home ( /home/user ) is untouched. 

At this login, the xfdesktop has 98 proccess. 

I had this problem in two of my machines ( work and House ). 

Now, I will clear the config of xfce4 ( ~/.config/xfce4 ) to try.

If I don't have the solution cleaning the config, the problem isn't solved :(

Comment 4 Ataliba Teixeira 2011-08-23 14:01:32 UTC
Well, I try to clear the config of xfce4 and the problem is here again. 

Now, I had 95 process of xfdesktop. 

I will try now to clear the xfce-sessions.

Comment 5 Ataliba Teixeira 2011-10-22 16:06:34 UTC
Hello, 

I tried two workarounds to solve this problem.

One, is a shell script to kill all xfdestkop process on my login : 

#!/bin/sh 

{

   while true 
    do 
          sleep 2
          
          Count=$(ps aux | grep xfdesktop | grep -v killxfdesktopd | grep -v grep | wc -l)

          if [ $Count -gt 1 ]; then 
             /usr/bin/logger -t XFDesktopd "Killing XFDesktop Process"
	     kill -9 $(ps aux | grep xfdesktop | grep -v killxfdesktopd |awk -F" " '{print $2}')
          else 
	    if [ $Count -eq 0 ]; then 
                /usr/bin/logger -t XFDesktopd "Starting XFDesktop Process"
  		/usr/bin/xfdesktop & 
            fi
	  fi
    done
          
} & 


But this script is giving me some problems with some xfdesktop components. 

Today, I see a workaround on ubuntu launchpad ( https://bugs.launchpad.net/ubuntu/+source/xfdesktop4/+bug/329616 ) 

Here, this workaround solves my problem. 

I made this: 

1. rm -rf ~/.cache/sessions/*
   This delete all the xfdesktop sessions
2. logout 
3. ctrl+alt+f(x)
4. rm -rfv /home/youruser/.config/sessions/*

I reboot my system and now ... I don't have problems. 

On the launchpad the user send another workarounds to solve this problem. 

I believe I had many sessions saved and my xfdesktop had problems to manage them.

Comment 6 Fedora End Of Life 2012-08-07 19:55:18 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.