Bug 73260 - search existing drives for CD before prompting
search existing drives for CD before prompting
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-01 20:39 EDT by Jay Berkenbilt
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 11:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2002-09-01 20:39:42 EDT
My system has two CD-ROM drives.  I notice that if I place install disc 1 in one
drive and install disc 2 in the second drive, anaconda notices this fact and
does not prompt me for disc 2 after it finishes with disc 1's package.  Great
feature!  I was impressed that this worked.

During my install, when I noticed that the light on the second disc was on but
not on the first disc, I removed disc 1 from my first drive and loaded disc 3. 
When anaconda got to the end of disc 2, it prompted me for disc 3.  I simply hit
return and it continued, finding disc 3.

It would be nice (I considered the words, "slick," or "sleek," but ultimately
settled on "nice") if it would detect that disc 3 had been loaded (presumably by
doing the same thing it did to notice that both discs 1 and 2 were available
before) before it asked me to insert disc 3.  Then I wouldn't ever have to hit
return to continue with a new disc.  This means that I could walk away during
the install (after reading all the haiku, of course) and come back any time
during disc 2 to change discs instead of having to be there at the moment when
disc 3 was needed.

I suspect this will get deferred to a future release, but I hope this suggestion
will eventually be considered.  I bet it wouldn't be hard to implement, given
that this type of detection is already done at the beginning of the process.
Comment 1 Michael Fulbright 2002-09-02 11:06:44 EDT
This was a bug I've fixed since the 'null' beta.

If you replace disc 1 with disc 3 while disc 2 is being used it should 'just work'.

Comment 2 Ben Levenson 2002-09-04 19:23:44 EDT
fix verified.
Closing -> RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.