Bug 732606 - error: rpmdb open failed
Summary: error: rpmdb open failed
Keywords:
Status: CLOSED DUPLICATE of bug 705950
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:9bf704f11a7780a0b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 05:20 UTC by Peter H. Jones
Modified: 2011-08-24 14:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 14:12:23 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (484.95 KB, text/plain)
2011-08-23 05:20 UTC, Peter H. Jones
no flags Details
Attached traceback automatically from anaconda. (428.58 KB, text/plain)
2011-08-23 07:18 UTC, Peter H. Jones
no flags Details

Description Peter H. Jones 2011-08-23 05:20:00 UTC
The following was filed automatically by anaconda:
anaconda 15.31 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1107, in simpleDBInstalled
    mi = self.ts.ts.dbMatch('name', name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1125, in isPackageInstalled
    installed = self.simpleDBInstalled(name)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 1309, in _compare_providers
    if self.isPackageInstalled(po.base_package_name):
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 584, in _requiringFromTransaction
    pkgresults = self._compare_providers(pkgs, requiringPo)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 269, in _processReq
    CheckDeps, missingdep = self._requiringFromTransaction(po, requirement, errormsgs)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 862, in _resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 742, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 951, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1486, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 199, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 234, in currentStep
    self.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1290, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1476, in setup_window
    self.setScreen()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1490, in run
    self.setup_window(False)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1221, in run
    self.icw.run()
  File "/usr/sbin/anaconda", line 925, in <module>
    anaconda.intf.run(anaconda)
error: rpmdb open failed

Comment 1 Peter H. Jones 2011-08-23 05:20:05 UTC
Created attachment 519392 [details]
Attached traceback automatically from anaconda.

Comment 2 Peter H. Jones 2011-08-23 05:41:24 UTC
This happened when rebooting at the end of a preupdate from F14 to F15. Actually, I ran the preupdate a few days ago, in order to accumulate the rpm's in the /var/cache/hum/upgrade/... directory. A day or so later, I was urged by PackageKit to install some 1400 updates, which turned out to be for F15. I installed only the 3 security updates.

I backed up the system just before rerunning preupdate.

During the reboot, the system seemed to run very slowly. Then, I discovered touching the CTRL key caused it to advance. It was as if it were scrolling, and waiting for a keypress to continue.

This system has 500 M of memory. Maybe that's not enough.

Comment 3 Peter H. Jones 2011-08-23 07:18:28 UTC
Created attachment 519398 [details]
Attached traceback automatically from anaconda.

Comment 4 Peter H. Jones 2011-08-23 13:20:16 UTC
Previous traceback resulted from trying to preupgrade from F14 to F16 Alpha. Still seems to crash the same way.

Comment 5 Chris Lumens 2011-08-24 14:12:23 UTC

*** This bug has been marked as a duplicate of bug 705950 ***


Note You need to log in before you can comment on or make changes to this bug.