Bug 732679 - Missing group when installing RHEL 5.6 (or 5.7) with xen through kickstart file
Summary: Missing group when installing RHEL 5.6 (or 5.7) with xen through kickstart file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 10:13 UTC by Jack Zhou
Modified: 2011-09-06 17:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 17:53:40 UTC


Attachments (Terms of Use)
Screenshots and installation logs (168.58 KB, application/zip)
2011-08-24 01:59 UTC, Jack Zhou
no flags Details
Logs for using key to install RHEL 5.7 (87.87 KB, application/zip)
2011-08-26 05:48 UTC, Jack Zhou
no flags Details

Description Jack Zhou 2011-08-23 10:13:23 UTC
Description of problem:
  When using kickstart file to install RHEL 5.6 (or 5.7) x86_64 with xen to the target machine through text mode, a "missing group" message was informed as follow:
  You have specified that the group 'virtualization' should be installed. This group does not exist. Would you like to continue or abort your installation?
  The installation process is executed by means of NFS. The installation tree locate in NFS server. The kickstart file rhel5_xen.ks I specified looks as follow:

install
key --skip
lang en_US.UTF-8
langsupport --default en_US.UTF-8 en_US.UTF-8
timezone America/New_York
keyboard us
mouse genericwheelps/2 --device psaux
text
skipx
network --bootproto dhcp
firewall --enabled
rootpw password
authconfig --enableshadow --enablemd5
bootloader --location=mbr --append="rhgb quiet"
reboot
selinux --enforcing
zerombr yes
clearpart --all
part /boot --fstype ext3 --size=100
part / --fstype ext3 --grow --size=1024
part swap --size=512 --grow --maxsize=1024
%packages --resolvedeps
@ base-x
@ web-server
@ smb-server
@ printing
@ text-internet
@ server-cfg
@ dialup
@ admin-tools
@ gnome-desktop
@ graphical-internet
@ legacy-software-development
@ virtualization
kernel-xen
grub
rpm-build
rpm-libs
perl
bash
libusb
libusb-devel
%post

  It has a group "@ virtualization" in the %packages section. I didn't found the group definition in the file Server/repodata/comps-rhel5-server-core.xml in RHEL 5.6 (or 5.7) OS image. It's definition can be found in VT/repodata/comps-rhel5-vt.xml in RHEL 5.6 (or 5.7) OS image. "virtualization" is a category and include group "xen" and "kvm" which are also defined in VT/repodata/comps-rhel5-vt.xml. When I modified the kickstart file and replaced "@ virtualization" with "@ xen", the problem still appear.
  In the step of "missing group", choose "Continue", the OS installation will continue and succeed. But the packages specified by group "virtualization" will not be installed.
  When I use RHEL 5.6 DVD image to finish OS installation through graphic mode, the problem will not appear ( a selection form will be informed, select "Virtualization", these packages will be installed). I replace rhel5_xen.ks with the auto-generated ks file by installation of graphic mode and execute the previous NFS installation, the graphic installation interface will be executed and the "group missing" problem will not appear. The anto-generated ks file looks as follow:

install
cdrom
key 2515dd4e215225dd
lang en_US.UTF-8
keyboard us
xconfig --startxonboot
network --device eth0 --bootproto dhcp
network --device eth1 --onboot no --bootproto dhcp
rootpw --iscrypted $1$oqCdoez6$IXAsU19VG18lOu89F91xc1
firewall --enabled --port=22:tcp
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc Asia/Shanghai
bootloader --location=mbr --driveorder=sda --append="rhgb quiet"

%packages
@admin-tools
@base
@core
@development-libs
@development-tools
@dialup
@editors
@gnome-desktop
@gnome-software-development
@games
@graphical-internet
@graphics
@java
@legacy-software-support
@office
@printing
@sound-and-video
@text-internet
@web-server
@x-software-development
@base-x
@xen
kexec-tools
iscsi-initiator-utils
bridge-utils
fipscheck
device-mapper-multipath
sgpio
python-dmidecode
imake
emacs
libsane-hpaio
mesa-libGLU-devel
xorg-x11-utils
xorg-x11-server-Xnest
xorg-x11-server-Xvfb

  If I change the ks file into installation of text mode, like previous NFS installation of text mode, the problem still appeared!!!
  I don't know why this problem has always appeared in the installation of text mode. According to the official description in http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Virtualization/chap-Virtualization-Installing_the_virtualization_packages.html#sect-Virtualization-Installing_the_virtualization_packages-Installing_Xen_with_a_new_Red_Hat_Enterprise_Linux_installation, the problem should not appear. But now the problem always appeared in the installation of text mode.


Version-Release number of selected component (if applicable):
anaconda for RHEL 5.6 x86_64
anaconda for RHEL 5.7 x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup installation tree on the NFS server, and specify rhel5_xen.ks described above as the ks file. 
2. Install RHEL 5.6 (or 5.7) x86_64 with xen to the target machine through text mode.
  
Actual results:
  A "Missing group" interface will appear in the os installation process (text mode).

Expected results:
  The "Missing group" interface doen't appear and the virtualization packages can be auto-installed through text mode.


Additional info:

Comment 1 Chris Lumens 2011-08-23 13:59:37 UTC
In order to access the packages in the virtualization repo, you need to specify a key that gives you access to it.  I notice you're doing "key --skip", so that's what the problem is.

Comment 2 Jack Zhou 2011-08-24 01:52:36 UTC
(In reply to comment #1)
> In order to access the packages in the virtualization repo, you need to specify
> a key that gives you access to it.  I notice you're doing "key --skip", so
> that's what the problem is.

The key option is in the auto-genearted ks file. But when I changed it into text mode and executed the installation, the issue didn't disappear. In addition, I added the option "key 2515dd4e215225dd" into rhel5_xen.ks directly and executed the installation, the issue appeard as before.

Comment 3 Jack Zhou 2011-08-24 01:59:54 UTC
Created attachment 519543 [details]
Screenshots and installation logs

Comment 4 Chris Lumens 2011-08-24 15:46:17 UTC
In your attachment, I see:

21:00:07 INFO    : skipping install key

and:

21:00:08 INFO    : package paths is {'base': ['file:///mnt/source/./Server']}

So, these logs do not coincide with an installation that used a key.  Could you please attach logs from that run, so I can see what (if anything) is going wrong with the processing of that kickstart command?

Comment 5 Jack Zhou 2011-08-26 05:48:57 UTC
Created attachment 520007 [details]
Logs for using key to install RHEL 5.7

Comment 6 Jack Zhou 2011-08-26 05:54:21 UTC
(In reply to comment #4)
> In your attachment, I see:
> 
> 21:00:07 INFO    : skipping install key
> 
> and:
> 
> 21:00:08 INFO    : package paths is {'base': ['file:///mnt/source/./Server']}
> 
> So, these logs do not coincide with an installation that used a key.  Could you
> please attach logs from that run, so I can see what (if anything) is going
> wrong with the processing of that kickstart command?

I have attached the logs for using key to install RHEL 5.7. The ks file I1jw5lEgIG is used in the installation process. the ks file anaconda-ks.cfg is generated by anaconda when the installation completed.

Comment 7 Chris Lumens 2011-09-06 17:53:40 UTC
Okay, I see what's going on now.  So, your kickstart file is asking for a group named Virtualization and your logs say there's no such group.  Looking at the comps, I can tell that is correct - there is no Virtualization group.  In the anaconda screen we call "task selection", it offers a checkbox for virt however that does not map to a single group.  If you check it, you get the xen group installed.

In summary, what you probably want to do is remove "@virtualization" from your kickstart file and replace it with either "@xen" or "@kvm", depending on which you want.


Note You need to log in before you can comment on or make changes to this bug.