Bug 732724 - Resource leak
Summary: Resource leak
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypserv
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Honza Horak
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 734365 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 11:46 UTC by Michal Luscon
Modified: 2011-12-06 10:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:01:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1557 normal SHIPPED_LIVE ypserv bug fix and enhancement update 2011-12-06 00:39:22 UTC

Description Michal Luscon 2011-08-23 11:46:03 UTC
Description of problem:

/rpc.yppasswdd/update.c:1003 - Function external_update_pipe returns without freeing variable parentmsg. 

Version-Release number of selected component (if applicable):
ypserv-2.19-20.el6


Additional info:
This defect was not introduced in the previous supported version of ypserv package.

Comment 7 Honza Horak 2011-08-30 08:38:38 UTC
*** Bug 734365 has been marked as a duplicate of this bug. ***

Comment 8 Michal Luscon 2011-09-07 13:12:19 UTC
Mentioned resource leak was fixed and that was verified by the scan of current version of package.

Comment 10 errata-xmlrpc 2011-12-06 10:01:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1557.html


Note You need to log in before you can comment on or make changes to this bug.