Bug 732732 - swat can't write to logs
Summary: swat can't write to logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted
Version: 5.7
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 12:35 UTC by Ales Zelinka
Modified: 2012-02-21 05:48 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-2.4.6-317.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:48:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0158 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2012-02-20 14:53:50 UTC

Description Ales Zelinka 2011-08-23 12:35:29 UTC
Description of problem:
Samba's web admin tool can't write to samba logs:

time->Mon Aug 22 15:15:14 2011
type=SYSCALL msg=audit(1314040514.664:521): arch=c000003e syscall=2 success=no exit=-13 a0=2abeab81a940 a1=441 a2=1a4 a3=6e696b636f6c2065 items=0 ppid=22015 pid=22134 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="swat" exe="/usr/sbin/swat" subj=root:system_r:swat_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1314040514.664:521): avc:  denied  { write } for  pid=22134 comm="swat" name="samba" dev=dm-0 ino=4751475 scontext=root:system_r:swat_t:s0-s0:c0.c1023 tcontext=system_u:object_r:samba_log_t:s0 tclass=dir
----



Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-316.el5.noarch

Steps to Reproduce:
1.start/stop samba daemons via swat

Comment 1 Miroslav Grepl 2011-08-23 13:01:14 UTC
We have this in RHEL6.

Comment 3 Miroslav Grepl 2011-09-29 11:25:27 UTC
Fixed in selinux-policy-2.4.6-317.el5

Comment 6 errata-xmlrpc 2012-02-21 05:48:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html


Note You need to log in before you can comment on or make changes to this bug.