Bug 732743 - RHEL 6 deployable fails to launch in RHEV-M 3.0
Summary: RHEL 6 deployable fails to launch in RHEV-M 3.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
Assignee: Richard Su
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 13:20 UTC by Marcelo Giles
Modified: 2018-11-28 21:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:10:53 UTC


Attachments (Terms of Use)
Attached imagefactoy.log. Shows successful image build but failed push. (49.13 KB, application/octet-stream)
2011-08-23 13:20 UTC, Marcelo Giles
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0588 normal SHIPPED_LIVE new packages: imagefactory 2012-05-15 22:31:27 UTC

Description Marcelo Giles 2011-08-23 13:20:02 UTC
Created attachment 519460 [details]
Attached imagefactoy.log. Shows successful image build but failed push.

Description of problem:

RHEL 6.1 x86_64 builds fine and is uploaded into RHEV 3.0 public beta 1 but the push process reports failure:

# aeolus-image push --provider rhevm --id 6ba31dd8-82e4-44cd-857a-3220472c8f50

Provider Image: 3423a9f0-21e4-4bf6-92c5-48e057d18788
Image: 6ba31dd8-82e4-44cd-857a-3220472c8f50
Build: c0395100-e705-469e-a06c-9c311840a071
Status: PUSHING
Percent Complete: 0

# tail -f /var/log/imagefactory.log
...changed status from PUSHING to FAILED

The image is not shown as being successfully pushed into RHEV:

# aeolus-image list --images
IMAGE ID                                 LASTEST PUSHED BUILD     NAME 		TARGET     OS         OS VERSION     ARCH       DESCRIPTION         
6ba31dd8-82e4-44cd-857a-3220472c8f50                              rhel61	rhevm      RHEL-6     1              x86_64     rhel 6.1 x86_64 

But this image then becomes available as a template under RHEV-M and VMs can be created and run using it.

Problem is, after you create a deployable, if you try to launch it, it fails with what I think is a wrong RHEV REST API call.

Deployable xml:

<deployable name="Sample">
 <description>This is an example deployment</description>
 <assemblies>
  <assembly name="frontend" hwp="hwp1">
   <image id="6ba31dd8-82e4-44cd-857a-3220472c8f50">
   </image>
  </assembly>
 </assemblies>
</deployable>

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Marcelo Giles 2011-08-23 13:23:42 UTC
Error message shown in Conductor

Some assemblies will not be launched:
frontend: rhev3: image is not pushed to this provider account

Comment 2 Richard Su 2011-09-10 01:10:52 UTC
Submitted patch to deltacloud-dev. 

Start instance call fails with <template id="namevalue"> but succeeds with
<template><name>namevalue</name></template>. Possibly a bug in RHEV API.

Comment 3 Richard Su 2011-09-14 22:32:54 UTC
Waiting on feedback from RHEV team

https://fedorahosted.org/rhevm-api/ticket/284
https://fedorahosted.org/rhevm-api/ticket/285

Comment 4 wes hayutin 2011-09-28 16:37:26 UTC
making sure all the bugs are at the right version for future queries

Comment 6 Richard Su 2011-09-30 22:11:47 UTC
Works with:

aeolus-all-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-conductor-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-configure-2.0.2-4.20110928090214git4df04ad.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
iwhd-0.98.15.z3-2.fc15.x86_64
imagefactory-0.6.2-1.fc15.noarch
deltacloud-core-0.5.0-0.1.1317167702git.noarch
deltacloud-core-rhevm-0.5.0-0.1.1317167702git.noarch
rubygem-deltacloud-client-0.4.0-3.fc15.noarch

Tested build, push, and deploy RHEL 6.1 x86_64 image.

Comment 7 Dave Johnson 2011-10-03 14:57:32 UTC
Was able to build/push/deploy with the following rpms and template

aeolus-all-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-conductor-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-configure-2.0.2-4.20110928090214git4df04ad.fc15.noarch
deltacloud-core-0.5.0-0.1.1317167702git.noarch
deltacloud-core-ec2-0.5.0-0.1.1317167702git.noarch
deltacloud-core-rhevm-0.5.0-0.1.1317167702git.noarch
deltacloud-core-vsphere-0.5.0-0.1.1317167702git.noarch
imagefactory-0.6.2-1.fc15.noarch
iwhd-0.98.15.z3-2.fc15.x86_64
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
rubygem-deltacloud-client-0.4.0-3.fc15.noarch
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch

<template>
  <name>rhel6_1_x86_64_with_cRepo_and_cmake</name>
  <os>
    <name>RHEL-6</name>
    <version>1</version>
    <arch>x86_64</arch>
    <install type='iso'>
       <iso>http://127.0.0.1/rhel-server-6.1-x86_64-dvd.iso</iso>
    </install>
  </os>
  <description>rhel 6.1 x86_64 template with cmake pkg and custome repo</description>
  <packages>
    <package name='cmake'/>
  </packages>
  <repositories>
    <repository name="custom">
      <url>http://repos.fedorapeople.org/repos/aeolus/conductor/testing/6Server/x86_64/</url>
      <signed>false</signed>
    </repository>
  </repositories>
</template>

Comment 9 errata-xmlrpc 2012-05-15 20:10:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0588.html


Note You need to log in before you can comment on or make changes to this bug.