Bug 732755 - 3.1rc2 and rc3 fails to boot on EFI 32 MacMini2,1
Summary: 3.1rc2 and rc3 fails to boot on EFI 32 MacMini2,1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: John Feeney
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 13:57 UTC by Mads Kiilerich
Modified: 2013-01-10 07:40 UTC (History)
7 users (show)

Fixed In Version: kernel-3.1.0-0.rc5.git0.0.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 15:33:57 UTC


Attachments (Terms of Use)
dmesg from 3.0.1-3 - I don't get as far as interacting with 3.1 (122.43 KB, text/plain)
2011-08-23 13:57 UTC, Mads Kiilerich
no flags Details

Description Mads Kiilerich 2011-08-23 13:57:52 UTC
Created attachment 519468 [details]
dmesg from 3.0.1-3 - I don't get as far as interacting with 3.1

kernel-PAE-3.0.1-3.fc16.i686 works
but exactly the same grub2 setup with
kernel-PAE-3.1.0-0.rc2.git7.2.fc16.i686 or
kernel-PAE-3.1.0-0.rc3.git0.0.fc16.i686 fails. It just hangs after grub have loaded initrd and handed over control.

I saw a similar problem on an iMac 64-bit when grub gfxpayload was set. Phcoder made a patch for disabling that in EFI mode. Mjg59 mentioned another approach and kernel changes.

http://www.smolts.org/client/show/pub_f8de9376-1430-4cea-9095-c78df3bb7235

The 3.1 kernels work ok on iMac 64-bit.

Comment 1 Matthew Garrett 2011-08-23 14:22:41 UTC
Suspect this is the rtc code changes.

Comment 2 Mads Kiilerich 2011-08-24 13:02:13 UTC
I noticed that the same machine with 3.0.1-3 reports

Oops:efitime: can't read time!
i915 ... Invalid ROM contents
[drm:intel_parse_bios] *ERROR* VBT signature missing

Comment 3 Mads Kiilerich 2011-08-30 13:06:00 UTC
kernel-PAE-3.1.0-0.rc4.git0.0.fc16.i686 fails too.

Comment 4 Matthew Garrett 2011-08-30 15:38:40 UTC
This is caused by ef68c8f87ed13f65df867dddf36c0e185b27b942

Comment 5 Mads Kiilerich 2011-09-09 15:21:19 UTC
Confirmed, kernel-3.1.0-0.rc4.git0.1.fc16 can boot.

Comment 6 Fedora Update System 2011-09-09 15:43:10 UTC
kernel-3.1.0-0.rc5.git0.0.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc5.git0.0.fc16

Comment 7 Fedora Update System 2011-09-12 03:42:08 UTC
kernel-3.1.0-0.rc5.git0.0.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.