Bug 732763 - do not print traceback in yum/pup/* but raise exception which inherit from YumBaseError
Summary: do not print traceback in yum/pup/* but raise exception which inherit from Yu...
Keywords:
Status: CLOSED DUPLICATE of bug 751292
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin
Version: 6.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 745167 (view as bug list)
Depends On: 688637
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 14:12 UTC by Miroslav Suchý
Modified: 2018-11-15 08:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 688637
Environment:
Last Closed: 2011-11-24 15:07:55 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2011-08-23 14:12:02 UTC
+++ This bug was initially created as a clone of Bug #688637 +++

Created attachment 486039 [details]
pup crash dump

Description of problem:
The update tool (pup) failed during this morning's update. I have attached the crash dump.


Version-Release number of selected component (if applicable): 3.2.22


How reproducible:
Not reproducible on my system -- pup now reports that there are no new updates available.

Steps to Reproduce:
1. Click Apply Updates button in the Package Updater.
2.
3.
  
Actual results:
Package updater retrieves packages, installs them, and fails at what appears to be near the end  of the cleanup phase.

Expected results:
successful completion without a crash :)

Additional info:
I have attached the crash "dump" from pup.

--- Additional comment from james.antill@redhat.com on 2011-03-21 14:39:03 EDT ---

  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 704, in send_http
    headers=self.headers)
  File "/usr/lib64/python2.4/httplib.py", line 810, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.4/httplib.py", line 833, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.4/httplib.py", line 804, in endheaders
    self._send_output()
  File "/usr/lib64/python2.4/httplib.py", line 685, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.4/httplib.py", line 664, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.4/site-packages/rhn/SSL.py", line 217, in write
    sent = self._connection.send(data)
SysCallError: (104, 'Connection reset by peer')

...we can't really do anything above the rhn layer, as we aren't expecting to hit the network in posttrans (plus we'd have no idea what to do). I guess you probably want to retry, and/or ignore.

[SNIP]

--- Additional comment from msuchy@redhat.com on 2011-08-23 10:09:23 EDT ---

I would say this is valid BZ.
We should catch all exception and re-raise them is YumBaseError - or some Exception which inherit from YumBaseError, then pulp - or yum or whoever. Should do its best to corectly behave (and they do). But they simply do not expect from plugin anything then YumBaseError.

Although this is not material for RHEL5.8 as the original problem is definitely temporary network error and the fix is only not showing user traceback, but some nice error message. I'm going to close this BZ, but will clone it for RHEL6.

Comment 2 Jan Pazdziora 2011-11-24 10:27:02 UTC
Miroslav, is it correct to assume that this bugzilla is about pup, not pulp?

Comment 3 Jan Pazdziora 2011-11-24 10:38:48 UTC
Is this a duplicate of bug 745167?

Comment 4 Miroslav Suchý 2011-11-24 10:50:44 UTC
Yes, and yes.

Comment 5 Miroslav Suchý 2011-11-24 10:51:13 UTC
*** Bug 745167 has been marked as a duplicate of this bug. ***

Comment 6 Jan Pazdziora 2011-11-24 11:03:37 UTC
Thanks. In that case, would bug 751292 be also a dupe?

Comment 7 Miroslav Suchý 2011-11-24 15:07:55 UTC
Yes. And since bug 751292 has better history (mainly reference to bz where is already fix) I will mark this one as duplicate.

*** This bug has been marked as a duplicate of bug 751292 ***

Comment 8 Šimon Lukašík 2018-11-15 08:38:20 UTC
Lukašík Expunge


Note You need to log in before you can comment on or make changes to this bug.