Bug 732766 - SPICE client in full-screen mode at 800x600, shifts screen to the right
Summary: SPICE client in full-screen mode at 800x600, shifts screen to the right
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Alon Levy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 14:21 UTC by Bill Sanford
Modified: 2012-03-06 13:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-06 13:18:04 UTC


Attachments (Terms of Use)

Description Bill Sanford 2011-08-23 14:21:43 UTC
Description of problem:
When using a VM at an 800x600 resolution, and you go to full-screen, there is about a 2" black gap where the display has been shifted to the right.

Version-Release number of selected component (if applicable):
ic136

How reproducible:
100% 

Steps to Reproduce:
1. Set VM display to 800x600.
2. If not in full-screen, type Shift-F11 to go to full-screen.
3. 
  
Actual results:
The display is shifted to the right.

Expected results:
The display is centered and fully visible.

Additional info:
I have VM's with and without vdagent running. 

The local display is set to 1280x1024. The 1280x960, 1280x800, 1152x864, 1024x768 displays are balanced when full-screen is chosen. In 1280x960, 1280x800 I saw the VM in the middle of the display, with black borders on top and bottom and still had a full-screen. 

The only display that is not full-screen is 800x600.

If I set the local display to 800x600, the VM display of 800x600 works.

Comment 2 Andrew Cathrow 2011-08-24 14:05:33 UTC
Late in the cycle for this. Need to target this for 6.3

Comment 4 David Blechter 2011-12-21 13:10:44 UTC
Bill,
Can you provide more details on client(s) and guest(s)?
Thanks

Comment 6 Bill Sanford 2011-12-22 19:18:55 UTC
I will retry and see if I can get the screen capture.

Comment 8 Bill Sanford 2012-02-09 19:54:26 UTC
Retested with ic153 and this seems to be fixed.


Note You need to log in before you can comment on or make changes to this bug.