Bug 732792 - SIGSEGV in memcpy when compiling tycho with maven
Summary: SIGSEGV in memcpy when compiling tycho with maven
Keywords:
Status: CLOSED DUPLICATE of bug 560232
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 15:42 UTC by Stanislav Ochotnicky
Modified: 2011-08-25 21:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 15:54:54 UTC


Attachments (Terms of Use)
hs_err log from the crash (66.10 KB, text/plain)
2011-08-23 15:42 UTC, Stanislav Ochotnicky
no flags Details

Description Stanislav Ochotnicky 2011-08-23 15:42:17 UTC
Created attachment 519483 [details]
hs_err log from the crash

Description of problem:
I was compiling java package (tycho) with maven and java received SIGSEGV. 

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-59.1.10.3.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. this might be more tricky since it's entirely possible some of my changes are triggering this. If needed I can retry with default versions.

Comment 1 Deepak Bhole 2011-08-23 15:54:54 UTC
From the looks of it, one or more jar/zip files are being opened by the VM, changed on disk, and being accessed again from the VM object. Because the VM uses mmap to open zip files, once the file contents change, there are memory errors.

This is a known issue (in OpenJDK and Oracle JDK). It is hard to fix in a correct manner without trading significant performance.

Marking dupe of original.

*** This bug has been marked as a duplicate of bug 560232 ***

Comment 2 Andrew John Hughes 2011-08-25 21:07:11 UTC
There's:

changeset:   2354:ee385b4e2ffb
user:        sherman
date:        Thu Mar 11 14:06:09 2010 -0800
summary:     6929479: Add a system property sun.zip.disableMemoryMapping to disable mmap use in ZipFile

I thought someone had backported this to 6 but I don't see it.


Note You need to log in before you can comment on or make changes to this bug.