This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 732800 - php-libvirt-debuginfo 0.4.4-1 is empty, *.so unstripped
php-libvirt-debuginfo 0.4.4-1 is empty, *.so unstripped
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Novotny
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2011-08-23 12:45 EDT by Ville Skyttä
Modified: 2014-02-02 17:38 EST (History)
3 users (show)

See Also:
Fixed In Version: php-libvirt-0.4.4-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 20:03:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2011-08-23 12:45:51 EDT
php-libvirt-debuginfo 0.4.4-1 is empty and the *.so unstripped because the *.so is not installed with executable perms; it needs to be executable in order for rpmbuild's debuginfo stuff to do its job.

Fix:

--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -68,2 +68,3 @@ rm -rf %{buildroot}
 make install DESTDIR=%{buildroot}
+chmod +x %{buildroot}%{php_extdir}/php-libvirt.so
 

By the way, it would have been easy to catch this problem with rpmlint...
Comment 1 Michal Novotny 2011-08-24 03:43:08 EDT
(In reply to comment #0)
> php-libvirt-debuginfo 0.4.4-1 is empty and the *.so unstripped because the *.so
> is not installed with executable perms; it needs to be executable in order for
> rpmbuild's debuginfo stuff to do its job.
> 
> Fix:
> 
> --- a/php-libvirt.spec
> +++ b/php-libvirt.spec
> @@ -68,2 +68,3 @@ rm -rf %{buildroot}
>  make install DESTDIR=%{buildroot}
> +chmod +x %{buildroot}%{php_extdir}/php-libvirt.so
> 
> 
> By the way, it would have been easy to catch this problem with rpmlint...

Thanks for the patch, Ville. I'm applying it to the git tree right now ;-)

Thanks again,
Michal
Comment 2 Fedora Update System 2011-08-24 03:56:39 EDT
php-libvirt-0.4.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc14
Comment 3 Fedora Update System 2011-08-24 03:59:20 EDT
php-libvirt-0.4.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc15
Comment 4 Fedora Update System 2011-08-24 04:01:24 EDT
php-libvirt-0.4.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc16
Comment 5 Fedora Update System 2011-08-24 18:45:37 EDT
Package php-libvirt-0.4.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-libvirt-0.4.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-09-06 20:03:33 EDT
php-libvirt-0.4.4-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-09-06 20:22:08 EDT
php-libvirt-0.4.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2011-09-06 23:23:18 EDT
php-libvirt-0.4.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.