Bug 73282 - Dependency error in current rpms
Summary: Dependency error in current rpms
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdemultimedia   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-02 13:18 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 19:53:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-09-02 13:18:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
kdemultimedia-arts-3.0.3-3.i386.rpm fails to install due to problems in
dependencies against kdemultimedia-devel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Fvh kdemultimedia-devel-3.0.3-3.i386.rpm
2. rpm -Fvh kdemultimedia-arts-3.0.3-3.i386.rpm
3.
	

Actual Results:  error: Failed dependencies:
        kdemultimedia-arts = 3.0.3 is needed by (installed)
kdemultimedia-devel-3.0.3-3


Additional info:

Comment 1 Ngo Than 2002-10-16 16:00:40 UTC
You cannot update with single rpm package. Off course i breaks with dependency.

you have to use e.g:
rpm -Fvh kdemultimedia-devel-3.0.3-3.i386.rpm kdemultimedia-arts-3.0.3-3.i386.rpm

or better copy all kde rpm packages into a new directory and try with rpm -Fvh *


Comment 2 Need Real Name 2002-10-17 10:53:37 UTC
What I did was to download lots of stuff from rawhide and then doing something
equivalent to find . -name "*.rpm" > filelist
xargs rpm -Fvh <filelist
xargs splitted the argument list from find just after kdemutimedia-arts, 
kdemultimedia-args was installed without complaints but the next rmp -Fvh failed.
I counted on reorganizing the order of files in the filelist when dependency
problems occured. My point is that kdemultimedia-arts doesn't seem to define the
version tag 3.0.3 it probably defines 3.0.3-3. kdemutimedia-devel depends on the
tag 3.0.3.


Note You need to log in before you can comment on or make changes to this bug.