Bug 732848 - System boots, then goes to emergency mode
Summary: System boots, then goes to emergency mode
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ingo
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 21:58 UTC by Peter H. Jones
Modified: 2011-08-24 14:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 14:39:25 UTC


Attachments (Terms of Use)
dmesg of failing boot (53.61 KB, text/plain)
2011-08-23 21:58 UTC, Peter H. Jones
no flags Details
upgrade.log trying to preupgrade (6.33 MB, text/plain)
2011-08-23 22:01 UTC, Peter H. Jones
no flags Details
transaction that should do an upgrade (6.24 KB, text/plain)
2011-08-24 14:25 UTC, Peter H. Jones
no flags Details
standard output of attempt to upgrade (69.45 KB, text/plain)
2011-08-24 14:27 UTC, Peter H. Jones
no flags Details
error output of upgrade (2.07 KB, text/plain)
2011-08-24 14:29 UTC, Peter H. Jones
no flags Details

Description Peter H. Jones 2011-08-23 21:58:30 UTC
Created attachment 519525 [details]
dmesg of failing boot

Description of problem:
Boots, then goes to emergency mode. Can use mode 1 and rescue.

Version-Release number of selected component (if applicable):
Linux version 2.6.40.3-0.fc15.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Normal boot after an update
2.
3.
  
Actual results:
Emergency mode

Expected results:
Normal boot

Additional info:
I have tried to preupgrade from F14 to F15. I have a backup as of just before I hit the Reboot button (I hit cancel, then re-executed preupgrade and hit Reboot.). On reboot, I got an rpmdb backtrace, apparently due to lack of memory. See bug 705950 . After reboot, PackageKit wanted to install some 1440 updates, which were from fc15. However, yum repolist showed the repositories were at Fedora 14. I tried yum distrosync to set the version to 15, but I saw no effect. Then, I discovered the fedora-release rpm, which succeeded in changing the version. A full yum update fails with tangled dependencies, but I've been able to update subsets of files. However, my last update has resulted in an unbootable system. I will attach my dmesg output, and my update.log.

Comment 1 Peter H. Jones 2011-08-23 22:01:43 UTC
Created attachment 519526 [details]
upgrade.log trying to preupgrade

Comment 2 Jason Tibbitts 2011-08-23 23:07:41 UTC
I'm rather confused.  Ingo is a web-based sieve filter manager plugin for the Horde framework.  I'm not at all sure how it could possibly cause your system to go into emergency mode.

Comment 3 Peter H. Jones 2011-08-24 14:04:23 UTC
I picked a component at random. Perhaps this should have been reported as preupgrade bug. The problem is that the upgrade failed, causing a mixed system. Since reporting the bug, I was able to get into rescue mode and do some updates. I was able to use RPM to update enough for the system to boot and run. But now, I'm stuck with a huge number of updates to do, and conflict messages when I try to to update with yum.

Comment 4 Peter H. Jones 2011-08-24 14:25:20 UTC
Created attachment 519649 [details]
transaction that should do an upgrade

Here's a script that shows my attempts to finish upgrading my system. I got it by declining the result of a yum update and copying and pasting the list of files yum would download. That way, I can use my local disk with RPMs on it without re-downloading.

Comment 5 Peter H. Jones 2011-08-24 14:27:18 UTC
Created attachment 519650 [details]
standard output of attempt to upgrade

This shows the output of yum trying to upgrade with my rpm's. The failure occurs in the test transaction.

Comment 6 Peter H. Jones 2011-08-24 14:29:01 UTC
Created attachment 519651 [details]
error output of upgrade

Here is the output of the upgrade. I can't seem to find a smaller set of files to upgrade and get past the problem.

Comment 7 Jason Tibbitts 2011-08-24 14:39:25 UTC
"I picked a component at random."

I cannot help you; ingo has absolutely nothing to do with your problem.  I do not know how to solve your problem, and don't particularly wish to invest my time when you didn't even invest enough time to choose something reasonable against which to report your issue.

Nothing I can do but close this.


Note You need to log in before you can comment on or make changes to this bug.