Bug 732855 - Trying to load a Python plugin via peas in any app fails in Fedora 16
Summary: Trying to load a Python plugin via peas in any app fails in Fedora 16
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libpeas
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 22:45 UTC by Adam Williamson
Modified: 2011-09-17 00:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-17 00:38:06 UTC


Attachments (Terms of Use)

Description Adam Williamson 2011-08-23 22:45:17 UTC
As per summary, trying to load any Python plugin in any app that uses libpeas for its plugins fails in current F16:

(totem:19812): libpeas-WARNING **: Error initializing Python interpreter: could not import gi

you get that error from totem, gedit and rhythmbox, I tested each one.

I suspect the fix for this may be to bump to libpeas 1.1.2 with its pygobject3 dependency and adjust all libpeas client apps as well, but I didn't want to go ahead and do that myself in case it's too great a change and/or just wrong.

I kinda suspect this upstream commit may also have something to do with it:

http://git.gnome.org/browse/libpeas/commit/?id=0cee06c36977991d70ad627ceb3c40430b9dfcf9

"Adapt to and require gjs 1.29.16
gjs-gi was merged in gjs, so update the build system as well as path to headers."

and that one seems kinda orthogonal to the pygobject3 change.

Comment 1 Adam Williamson 2011-08-23 22:48:07 UTC
note that I did commit a libpeas bump to the master branch in git before totally grokking the consequences of such a change, but didn't get a build through for f17 or f16, so both still currently have libpeas 1.1.1 built against pygobject2.

Comment 2 Adam Williamson 2011-08-23 22:57:11 UTC
CCing J5 as Bastien is away for a bit.

Comment 3 Adam Williamson 2011-08-23 23:45:18 UTC
From #719791, Michel Salim:

"pygobject3 has been released upstream, and the Fedora review has just been completed.

pygobject2 on Rawhide has had its introspection support disabled, since that is now provided by pygobject3; packages depending on introspection would need to be updated to depend on pygobject3 on F-16 and above."

sounds like the root cause for this, right? So I seem to be right in supposing we need to go to libpeas 1.1.2 and rebuild stuff against pygobject3.

Comment 4 Bastien Nocera 2011-08-24 10:11:17 UTC
Can't update it until pygobject3 is in stable (Bodhi doesn't allow me to create a buildroot override as it says: "Error: You do not have commit privileges to pygobject3", even though I'm a proven packager).

Comment 5 Adam Williamson 2011-08-24 16:01:05 UTC
that's considered a bug in Bodhi, for now you can get it tagged manually if you ask dgilmore. anyway, i've +1ed the update so it triggered the autopush.

Comment 6 Matthias Clasen 2011-09-03 00:24:44 UTC
pygobject3 has made it out in the wild now.

Comment 7 Adam Williamson 2011-09-03 02:41:48 UTC
the giganto-gnome update has a fixed libpeas in it, i believe, so you could edit the update and mark it as fixing this bug, or we can just close this bug when the update goes through.

Comment 8 Bastien Nocera 2011-09-17 00:38:06 UTC
This should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.