Bug 732863 - lftp uses ipv6 addresses even when ipv6 is not available
lftp uses ipv6 addresses even when ipv6 is not available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lftp (Show other bugs)
6.1
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Hozza
Martin Frodl
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 20:58 EDT by Steven Shiau
Modified: 2015-04-08 03:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: lftp-4.0.9-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: The code handling errors while connecting to remote host didn't backed up the error value until checking it. The error value was therefore overwritten by a different error value before checking. Consequence: As a result, lftp failed to connect to a remote host if the client host didn't have IPv6 connection, but the remote host domain name was resolved also to IPv6 addresses. Therefore lftp failed to connect to the first IPv6 remote host address and existed. Fix: The error checking code was fixed to back up the appropriate error value before checking. Therefore the value is now not overwritten and the right error value is checked later on. Result: As a result lftp is not able to connect to a remote host which domain name resolves to also IPv6 addresses, from the client which has only IPv4 connectivity.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-08 03:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The patch fixes described issue (590 bytes, patch)
2011-12-08 04:24 EST, Jiri Skala
no flags Details | Diff

  None (edit)
Description Steven Shiau 2011-08-23 20:58:00 EDT
Description of problem:
lftp uses ipv6 addresses even when ipv6 is not available 

Version-Release number of selected component (if applicable):
$ rpm -q lftp
lftp-4.0.9-1.el6.i686

How reproducible:
Always

Steps to Reproduce:
1. $ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0C:29:1B:72:D9
          inet addr:192.168.120.2  Bcast:192.168.120.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3060 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2885 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:607125 (592.8 KiB)  TX bytes:386040 (376.9 KiB)
          Interrupt:19 Base address:0x2000

2. $ lftp -d http://ftp.twaren.net/Linux/
---- Connecting to ftp.twaren.net (2001:e10:5c00:5::9) port 80
**** connect: Network is unreachable
---- Closing HTTP connection
cd: Success

3. $ lftp -d http://releases.ubuntu.com/
---- Connecting to releases.ubuntu.com (2001:7b8:3:37::21:1) port 80
**** connect: Network is unreachable
---- Closing HTTP connection
cd: Success

  
Actual results:
As above.

Expected results:
$ lftp http://ftp.twaren.net/Linux/
cd ok, cwd=/Linux


Additional info:
1. Similar bug report is available here:
https://bugs.launchpad.net/ubuntu/+source/lftp/+bug/736479

2. After switching to lftp-4.2.1-1.fc15.i686.rpm or lftp-4.0.5-2.fc13.i686.rpm, this issue is gone.
Comment 2 RHEL Product and Program Management 2011-08-23 21:27:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Jiri Skala 2011-12-08 04:24:28 EST
Created attachment 542447 [details]
The patch fixes described issue

Attached patch corrects errno handling. This enables trying other IPs to connect. The patch fixes this issue for me.
Comment 5 Suzanne Yeghiayan 2012-02-14 18:14:23 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 RHEL Product and Program Management 2012-09-07 01:11:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2015-04-08 03:49:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0793.html

Note You need to log in before you can comment on or make changes to this bug.