Bug 732877 - faulty build because no BuildRoot set
Summary: faulty build because no BuildRoot set
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nc
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 02:54 UTC by JW
Modified: 2011-08-24 05:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 05:43:01 UTC


Attachments (Terms of Use)

Description JW 2011-08-24 02:54:32 UTC
Description of problem:
Build of nc appears to success but actually just bundles up existing installed nc files rather than freshly compiled files because no BuildRoot set in spec file.

Version-Release number of selected component (if applicable):
nc-1.100-2

How reproducible:
always

Steps to Reproduce:
1. rpmbuild -v -ba nc.spec
2.
3.
  
Actual results:
Old binary in generated rpm


Expected results:
New binary should be in rpm


Additional info:
This is a good test of your build procedure. The fact is that you haven't picked this up during regular builds.

Comment 1 Petr Šabata 2011-08-24 05:43:01 UTC
BuildRoot tag has been deprecated since Fedora 10, see the Packaging guidelines [1].  I haven't experienced this on Fedora 15 and it certainly doesn't happen in Koji.

If you're sure your environment isn't borked, file a bug with rpm[build].

[1] http://fedoraproject.org/wiki/PackagingGuidelines#BuildRoot_tag


Note You need to log in before you can comment on or make changes to this bug.