Bug 732920 - Scrolling the page while in promotion tab also scrolls the "production changeset" box
Summary: Scrolling the page while in promotion tab also scrolls the "production change...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-24 07:36 UTC by Sachin Ghai
Modified: 2013-08-16 18:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:24 UTC


Attachments (Terms of Use)
Screenshot of displaced proudction_changeset box (17.39 KB, image/png)
2011-08-24 07:37 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2011-08-24 07:36:09 UTC
Description of problem:
when you scroll the page after create a new changeset under promotions tab, this also scrolls the production changeset list box ( i.e. on right pane of screen).

Version-Release number of selected component (if applicable):
[root@dhcp201-167 ~]# rpm -qa | grep katello
katello-cli-0.1.5-1.git.15.654a7df.fc15.noarch
katello-0.1.70-1.git.7.ca8d03c.fc15.noarch
[root@dhcp201-167 ~]

How reproducible:
always

Steps to Reproduce:
1. create a changeset
2. scroll the page

  
Actual results:
Scrolling the page in promotion tab also scrolls the "production changeset" box

Expected results:
production changeset box shouldn't be scrolled.

Additional info:

Comment 1 Sachin Ghai 2011-08-24 07:37:40 UTC
Created attachment 519566 [details]
Screenshot of displaced proudction_changeset box

Comment 2 Mike McCune 2011-08-24 19:10:46 UTC
Lets make sure it does not scroll when the left pane is not longer than the current page.  This scrolling is intentional when you have a really long list but shouldn't scroll when it is within one page.

Comment 3 Eric Helms 2011-08-25 18:21:36 UTC
commit 120a6266e6a45900b9e09f3ebfc6f0e43fca02b9

This fixes the issue specifically seen on the promotions page with the right side panel moving when the window itself has a scroll bar.  This behavior could be seen on other pages as well for the new and edit boxes and should be fixed for them as well.

Comment 4 Jeff Weiss 2011-09-26 16:54:43 UTC
Not sure what the problem was, but the current build seems to behave as I would expect.  Verified, katello-0.1.84-1.git.26.51fa1e1.fc14.noarch

Comment 7 Mike McCune 2013-08-16 18:23:33 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.