Bug 732954 - issue8135 : urllib.unquote doesn't decode mixed-case percent escapes
Summary: issue8135 : urllib.unquote doesn't decode mixed-case percent escapes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python
Version: 5.8
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Dave Malcolm
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 734005 772956
TreeView+ depends on / blocked
 
Reported: 2011-08-24 09:36 UTC by Cedric Buissart 🐶
Modified: 2018-11-14 10:56 UTC (History)
4 users (show)

Fixed In Version: python-2.4.3-45.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 06:50:14 UTC


Attachments (Terms of Use)
backported upstream patch from 8135 (2.20 KB, patch)
2011-08-24 09:36 UTC, Cedric Buissart 🐶
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0297 normal SHIPPED_LIVE python bug fix update 2012-02-20 15:05:27 UTC
Python 8135 None None None Never

Description Cedric Buissart 🐶 2011-08-24 09:36:05 UTC
Created attachment 519580 [details]
backported upstream patch from 8135

Description of problem:

urllib.unquote fails to decode a percent-escape with mixed case. It has been reported / corrected upstream :
http://bugs.python.org/issue8135


Version-Release number of selected component (if applicable):

python-2.4.3-44.el5

How reproducible:

100%

Steps to Reproduce:

>>> from urllib import unquote
>>> unquote("%fc")
'\xfc'
>>> unquote("%FC")
'\xfc'
>>> unquote("%Fc")
'%Fc'
>>> unquote("%fC")
'%fC'

Expected behaviour:

>>> unquote("%Fc")
'\xfc'
>>> unquote("%fC")
'\xfc' 



Additional info:
attached : backported patch http://bugs.python.org/file16552/urllib-unquote-mixcase.patch2
I tried it, it seems fine to me

Comment 13 errata-xmlrpc 2012-02-21 06:50:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0297.html

Comment 14 Red Hat Bugzilla 2013-10-04 00:25:25 UTC
Removing external tracker bug with the id 'DOC-61659' as it is not valid for this tracker


Note You need to log in before you can comment on or make changes to this bug.