Bug 732978 - ModeShape FileSystemConnectorCreateWorkspacesTest is failing on Windows.
Summary: ModeShape FileSystemConnectorCreateWorkspacesTest is failing on Windows.
Keywords:
Status: VERIFIED
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Modeshape
Version: BRMS 5.2.0.GA
Hardware: All
OS: Windows
unspecified
low
Target Milestone: ---
: ---
Assignee: Van Halbert
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 11:16 UTC by Petr Široký
Modified: 2019-01-01 02:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-1246 None Resolved FileSystemConnectorCreateWorkspacesTest is failing on Windows. 2011-09-20 10:58:01 UTC

Description Petr Široký 2011-08-24 11:16:37 UTC
Description of problem:
FileSystemConnectorCreateWorkspacesTest.shouldBeAbleToCreateThenDestroyThenRecreateWorkspace is failing on Windows machines with following exception:


org.modeshape.graph.request.InvalidWorkspaceException: Could not create the directory "w:\workspace\brms-modeshape-single\modeshape\extensions\modeshape-connector-filesystem\something bogus2011-08-23T09:29:12.920-04:00" for the file system source "Test Repository"
	at org.modeshape.connector.filesystem.FileSystemRepository.createDirectory(FileSystemRepository.java:112)
	at org.modeshape.connector.filesystem.FileSystemRepository.getWorkspaceDirectory(FileSystemRepository.java:126)
	at org.modeshape.connector.filesystem.FileSystemWorkspace.<init>(FileSystemWorkspace.java:100)
	at org.modeshape.connector.filesystem.FileSystemRepository$FileSystemTransaction.getWorkspace(FileSystemRepository.java:192)
	at org.modeshape.connector.filesystem.FileSystemRepository$FileSystemTransaction.getWorkspace(FileSystemRepository.java:165)
	at org.modeshape.graph.connector.base.Repository.createWorkspace(Repository.java:236)
	at org.modeshape.graph.connector.base.Processor.process(Processor.java:452)
	at org.modeshape.graph.request.processor.RequestProcessor.process(RequestProcessor.java:253)
	at org.modeshape.graph.connector.base.Connection.execute(Connection.java:115)
	at org.modeshape.graph.Graph.execute(Graph.java:288)
	at org.modeshape.graph.Graph$5.process(Graph.java:231)
	at org.modeshape.graph.request.RequestBuilder.createWorkspace(RequestBuilder.java:89)
	at org.modeshape.graph.Graph$6.named(Graph.java:401)
	at org.modeshape.graph.connector.test.WorkspaceConnectorTest.shouldBeAbleToCreateThenDestroyThenRecreateWorkspace(WorkspaceConnectorTest.java:300)


I think that the problem is caused by directory name, because colons are not allowed in directory name on Windows.

How reproducible:
Run unit tests on Windows machine.

Comment 1 Van Halbert 2011-08-25 13:37:01 UTC
Commit ID:  fdc9b1d8101c31129d11
to ModeShape 2.5.x branch.

Comment 2 Petr Široký 2011-08-31 21:16:35 UTC
Verified fixed in 5.2.0 ER3.


Note You need to log in before you can comment on or make changes to this bug.