Bug 732987 - Matplotlib has broken build dependencies
Summary: Matplotlib has broken build dependencies
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-matplotlib
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 11:57 UTC by Oded Arbel
Modified: 2011-09-15 18:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 18:49:33 UTC


Attachments (Terms of Use)

Description Oded Arbel 2011-08-24 11:57:06 UTC
Description of problem:
When trying to build python-matplotlib on a newly installed CentOS 5 machine, the build fails mid way due to missing dependencies

Version-Release number of selected component (if applicable):
0.99.1.2-1

How reproducible:
Always

Steps to Reproduce:
1. Install a minimal CentOS 5
2. download python-matplotlib source RPM
3. install all the dependencies listed in BuildRequires and try to build matplotlib
  
Actual results:
The build fails to complete due to missing numpy development packages, and when that is satisfied it fails to build when it tries to use gcc to compile a c++ file.

Expected results:
The build should complete successfully.

Additional info:
The RPM spec files should list numpy-devel and gcc-c++ as a build requirements.

Comment 1 Jef Spaleta 2011-09-15 18:44:20 UTC
First, let me state that as per Fedora packaging guidance gcc-c++ is purposefully not part of the build requirements for any package. 

For reference, please see:
 http://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions_2

there are alternative compilers than gcc available for users. We try hard to to require any specific compiler and expect sysadmins to have prepped a build environment.

If you want to replicate the fedora build environment, I would suggest you look at using mock locally to prep a clean Fedora assumed environment. 

As for the numpy-devel, I'm not sure what to tell you there. Makes you wonder how this got through the build system back when this was build originally.  Maybe some other updated packages moved their devel bits around. 

For reference when I do a scratch build in koji from the git checkout of the packaging bits:
fedpkg build --scratch

I get a clean build.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3353821

This builds cleanly against the fedora buildsystem and if you look at the logs numpy is sufficient according to the koji build. Weird.

can you give me the full package name for the numpy you have installed?

-jef

Comment 2 Jef Spaleta 2011-09-15 18:49:33 UTC
numpy-devel does not appear to exist as a package for RHEL 5. Soooooo I have to wonder, is that maybe a numpy package you picked up out of tree? 

I'm closing this bug. I can't adjust the packaging for an EPEL package for builddeps which don't exist in the target build environment.

-jef


Note You need to log in before you can comment on or make changes to this bug.