Bug 733037 - Regression: DVI output no longer works
Summary: Regression: DVI output no longer works
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 14:54 UTC by Nathaniel McCallum
Modified: 2016-11-24 15:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 14:19:16 UTC


Attachments (Terms of Use)
dmesg on 3.1.0-0.rc3.git0.0.fc16.x86_64 (123.42 KB, text/plain)
2011-08-25 13:35 UTC, Nathaniel McCallum
no flags Details
Xorg log (46.34 KB, text/plain)
2011-08-25 13:35 UTC, Nathaniel McCallum
no flags Details

Description Nathaniel McCallum 2011-08-24 14:54:41 UTC
You can see the full details of my hardware and configuration in this bug: https://bugzilla.redhat.com/show_bug.cgi?id=707747

Everything worked fine in F15 with my dual monitors. When I upgraded to F16 Alpha, my DVI output disappeared (it is listed as HDMI3 in the xrandr output in the bug linked to above).

My current xrandr output looks like this:
Screen 0: minimum 320 x 200, current 1200 x 1920, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1600x900       60.0 +   50.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
DP2 connected 1200x1920+0+0 left (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  

Note the lack of HDMI3/DP3. I do have the DVI cable plugged in and nothing else has changed since my upgrade to F16 Alpha.

Comment 1 Dave Airlie 2011-08-24 16:20:15 UTC
dmesg? the 3.0 kernel or 3.1-rcX kernel?

Comment 2 Nathaniel McCallum 2011-08-24 16:40:40 UTC
The only interesting thing in dmesg is:
[drm:intel_dsm_pci_probe] *ERROR* failed to get supported _DSM functions

Interestingly, if I boot a f15 kernel I still get the same problem. I've tried:
kernel-3.0.1-3.fc16.x86_64
kernel-2.6.40.3-0.fc15.x86_64
kernel-3.1.0-0.rc2.git7.2.fc16.x86_64
kernel-3.1.0-0.rc3.git0.0.fc16.x86_64

Also interesting is that the boot splash used to show up on both of my monitors, but now just the one... Same for GDM...

Which kernel do you want dmesg for? Do you want Xorg.0.log as well?

Comment 3 Dave Airlie 2011-08-24 18:15:57 UTC
oh wierd, did you test fc15 with 2.6.40 before upgrading?

can you boot with drm.debug=4 on the 3.1.0-0-rc3 kernel, and make/model of the laptop.

Comment 4 Nathaniel McCallum 2011-08-25 13:34:27 UTC
I did not test 2.6.40 before upgrading.

Comment 5 Nathaniel McCallum 2011-08-25 13:35:29 UTC
Created attachment 519838 [details]
dmesg on 3.1.0-0.rc3.git0.0.fc16.x86_64

Comment 6 Nathaniel McCallum 2011-08-25 13:35:52 UTC
Created attachment 519839 [details]
Xorg log

Comment 7 Nathaniel McCallum 2011-08-25 14:17:11 UTC
Well, this is wierd... I just downgraded glibc to glibc-2.14.90-4.1 because it was causing a crash in pulseaudio, and all of a sudden DVI started working again. Is there some user-space component that is broken here?

Comment 8 Nathaniel McCallum 2011-08-25 14:27:40 UTC
I am unable to reproduce the problem with glibc-2.14.90-4.1 installed.

Comment 9 Mads Kiilerich 2011-08-25 14:33:49 UTC
The alpha contained glibc-2.14.90-4 - not glibc-2.14.90-6. Can you confirm that you only saw this after updating to updates-testing?

Comment 10 Nathaniel McCallum 2011-08-25 14:39:54 UTC
No because I didn't install the alpha but upgraded from f15 directly to updates-testing...

Comment 11 Nathaniel McCallum 2011-08-25 14:42:06 UTC
As it stands right now my system is fully updates-testing except for glibc which is 2.14.90-4 and everything works.

However, what I'm not understanding is why KMS would depend on glibc...

Comment 12 Mads Kiilerich 2011-08-25 14:46:59 UTC
Try to check /var/log/messages and dmesg (or abrt-gui) for coredumps. Some essential tool might have failed to do its job.

Comment 13 Mads Kiilerich 2011-08-25 14:47:41 UTC
btw: https://admin.fedoraproject.org/updates/glibc-2.14.90-6

Comment 14 Adam Jackson 2011-10-13 14:19:16 UTC
Reassigning to glibc, and closing since I suspect it's fixed in -10.  Please reopen if not.


Note You need to log in before you can comment on or make changes to this bug.