Bug 733042 - default rhsm.conf values need to be updated for production/stage environments
Summary: default rhsm.conf values need to be updated for production/stage environments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Devan Goodwin
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-08-24 14:59 UTC by John Sefler
Modified: 2011-12-06 17:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:23:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-08-24 14:59:05 UTC
Description of problem:
Some default values in the rhsm.conf file need to be corrected for production.
See all three "UPDATE TO"s below...
This is causing trouble for QE testing of rhel62 composes. Once updated, please initiate a new brew build.


Version-Release number of selected component (if applicable):
[root@jsefler-stage-6server tmp]# rpm -q subscription-manager
subscription-manager-0.96.6-1.el6.x86_64



Steps to Reproduce:
[root@jsefler-stage-6server tmp]# cat /etc/rhsm/rhsm.conf
# Red Hat Subscription Manager Configuration File:

# Unified Entitlement Platform Configuration
[server]
# Server hostname:
hostname = subscriptions.rhn.webqa.redhat.com
UPDATE TO: hostname=subscription.rhn.redhat.com

# Server prefix:
prefix = /subscription

# Server port:
port = 443

# Set to 1 to disable certificate validation:
insecure = 0

# Set the depth of certs which should be checked
# when validating a certificate
ssl_verify_depth = 3

# Server CA certificate location:
ca_cert_dir = /etc/rhsm/ca/

# an http proxy server to use
proxy_hostname =

# port for http proxy server
proxy_port = 

# user name for authenticating to an http proxy, if needed
proxy_user =

# password for basic http proxy auth, if needed
proxy_password =

[rhsm]
# Content base URL:
baseurl= https://mockamai.devlab.phx1.redhat.com
UPDATE TO: baseurl= https://cdn.redhat.com

# Default CA cert to use when generating yum repo configs:
repo_ca_cert = %(ca_cert_dir)sfakamai-cp1.pem
UPDATE TO: repo_ca_cert = %(ca_cert_dir)sredhat-uep.pem


# Where the certificates should be stored
productCertDir = /etc/pki/product
entitlementCertDir = /etc/pki/entitlement
consumerCertDir = /etc/pki/consumer

[rhsmcertd]
# Frequency of certificate refresh (in minutes):
certFrequency = 240

Comment 1 Devan Goodwin 2011-08-24 15:28:05 UTC
Fixed in subscription-manager.git: 5e25911a97d62d79a237e38e86ad15997448cb51

New build should arrive later today as soon as we can clear the patch ack queue.

Comment 3 John Sefler 2011-09-10 01:57:24 UTC
Verification...

[root@jsefler-onprem-62server tmp]# cat /etc/rhsm/rhsm.confcat: /etc/rhsm/rhsm.conf: No such file or directory
[root@jsefler-onprem-62server tmp]# rpm -i http://download.devel.redhat.com/brewroot/packages/subscription-manager/0.96.9/1.el6/x86_64/subscription-manager-0.96.9-1.el6.x86_64.rpm
[root@jsefler-onprem-62server tmp]# cat /etc/rhsm/rhsm.conf# Red Hat Subscription Manager Configuration File:

# Unified Entitlement Platform Configuration
[server]
# Server hostname:
hostname = subscription.rhn.redhat.com

# Server prefix:
prefix = /subscription

# Server port:
port = 443

# Set to 1 to disable certificate validation:
insecure = 0

# Set the depth of certs which should be checked
# when validating a certificate
ssl_verify_depth = 3

# Server CA certificate location:
ca_cert_dir = /etc/rhsm/ca/

# an http proxy server to use
proxy_hostname =

# port for http proxy server
proxy_port = 

# user name for authenticating to an http proxy, if needed
proxy_user =

# password for basic http proxy auth, if needed
proxy_password =

[rhsm]
# Content base URL:
baseurl= https://cdn.redhat.com

# Default CA cert to use when generating yum repo configs:
repo_ca_cert = %(ca_cert_dir)sredhat-uep.pem

# Where the certificates should be stored
productCertDir = /etc/pki/product
entitlementCertDir = /etc/pki/entitlement
consumerCertDir = /etc/pki/consumer

[rhsmcertd]
# Frequency of certificate refresh (in minutes):
certFrequency = 240


These default production parameters are good.
Moving to VERIFIED

Comment 4 errata-xmlrpc 2011-12-06 17:23:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.