This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 733046 - udisks-lvm-pv-export segfault after avc - and then system hangs for 2 minutes
udisks-lvm-pv-export segfault after avc - and then system hangs for 2 minutes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udisks (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-24 11:02 EDT by Mads Kiilerich
Modified: 2013-03-05 23:07 EST (History)
3 users (show)

See Also:
Fixed In Version: udisks-1.0.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-09 13:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
full dmesg (104.56 KB, text/plain)
2011-08-24 11:09 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2011-08-24 11:02:56 EDT
While booting a live usb I got:

[   14.013144] applesmc: key=276 fan=3 temp=35 acc=0 lux=0 kbd=0
[   14.383254] type=1400 audit(1314194721.539:4): avc:  denied  { create } for  pid=756 comm="udisks-lvm-pv-e" name="lvm" scontext=system_u:system_r:lvm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=dir
[   14.403692] udevd[776]: failed to execute '/sbin/initqueue' '/sbin/initqueue --settled --onetime --unique /sbin/dmsquash-live-root /dev/sdc1': No such file or directory
[   14.416732] udisks-lvm-pv-e[756]: segfault at 8 ip 00007fdc41a07ff4 sp 00007fff40a3f718 error 4 in liblvm2app.so.2.2[7fdc419a8000+8a000]
[   14.429782] udevd[494]: 'udisks-lvm-pv-export wNwVXG-MJeE-gI32-no33-RkZ7-n2hk-HovUXY' [756] terminated by signal 11 (Segmentation fault)
[   14.477901] logger[784]: /sbin/usb-mounter: action=add dev=/dev/sdc1
[   14.559619] logger[793]: /dev/sdc1 already mounted
[  132.051357] systemd[1]: udev-settle.service: main process exited, code=exited, status=1
[  132.073048] systemd[1]: Unit udev-settle.service entered failed state.
[  132.862280] systemd-tmpfiles[890]: Successfully loaded SELinux database in 9ms 979us, size on heap is 464K.

I don't know the root cause is, but:

1: the primary issue for the user is that the system hangs for 2 minutes waiting for something - I don't know where this problem is

2: there shouldn't be an avc - I don't know if that is a selinux or dracut issue or what.

3: udisks-lvm-pv-export shouldn't segfault no matter what - _that_ can be filed under udisks ...

udisks-1.0.3-2.fc16.x86_64
kernel-3.1.0-0.rc3.git0.0.fc16.x86_64
selinux-policy-targeted-3.10.0-18.fc16.noarch
dracut-013-4.fc16.noarch
udev-173-1.fc16.x86_64
Comment 1 Mads Kiilerich 2011-08-24 11:09:03 EDT
Created attachment 519658 [details]
full dmesg
Comment 2 Wade Mealing 2011-08-24 12:26:33 EDT
I can confirm, on both xfce and gnome "alpha" live cds'
Comment 3 Mads Kiilerich 2011-08-24 12:38:29 EDT
FWIW, on another compose on a different machine it neither segfaulted nor hang ... :

[   17.130371] applesmc: key=297 fan=1 temp=40 acc=0 lux=0 kbd=0
[   17.132103] input: HDA Intel PCH HDMI/DP as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   17.208033] type=1400 audit(1314203369.899:6): avc:  denied  { associate } for  pid=465 comm="udevd" name="live" dev=devtmpfs ino=7356 scontext=system_u:object_r:default_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=filesystem
[   17.208844] udevd[465]: setfilecon /dev/live failed: Permission denied
[   17.221178] udevd[647]: failed to execute '/sbin/initqueue' '/sbin/initqueue --settled --onetime --unique /sbin/dmsquash-live-root /dev/sdb': No such file or directory
[   17.245404] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Comment 4 Mads Kiilerich 2011-08-25 05:45:15 EDT
The udisks-lvm-pv-export avc has been reported in bug 733083.
Comment 5 David Zeuthen 2011-08-26 12:15:13 EDT
Version 1.0.4 (just built) actually doesn't have the udisks-lvm-pv-export tool (for other reasons)...
Comment 6 Fedora Update System 2011-08-26 12:17:00 EDT
udisks-1.0.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/udisks-1.0.4-1.fc16
Comment 7 Mads Kiilerich 2011-08-26 12:43:17 EDT
I guess the udev rule that started the tool also should be removed too so we don't get annoying error messages?

[root@imac ~]# grep udisks-lvm-pv-export $(rpm -ql udisks-1.0.4-1.fc16)
/lib/udev/rules.d/80-udisks.rules:ENV{ID_FS_TYPE}=="LVM2_member", TEST=="/lib/udev/udisks-lvm-pv-export", IMPORT{program}="udisks-lvm-pv-export $env{ID_FS_UUID}"
Comment 8 David Zeuthen 2011-08-26 12:58:39 EDT
(In reply to comment #7)
> I guess the udev rule that started the tool also should be removed too so we
> don't get annoying error messages?
> 
> [root@imac ~]# grep udisks-lvm-pv-export $(rpm -ql udisks-1.0.4-1.fc16)
> /lib/udev/rules.d/80-udisks.rules:ENV{ID_FS_TYPE}=="LVM2_member",
> TEST=="/lib/udev/udisks-lvm-pv-export", IMPORT{program}="udisks-lvm-pv-export
> $env{ID_FS_UUID}"

It's fine that way, actually - The TEST=="/lib/udev/udisks-lvm-pv-export" part ensures that we don't run the command since it's not there.

(It's done this way because building udisks with lvm support is optional and I didn't want to have to add complicated Makefile rules to build a 80-udisks.rules with or without lvm support. So it's harmless.)
Comment 9 Fedora Update System 2011-08-28 01:46:32 EDT
Package udisks-1.0.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing udisks-1.0.4-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/udisks-1.0.4-1.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-09-09 13:14:26 EDT
udisks-1.0.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.