Bug 733053 - Review Request: perl-Unicode-CheckUTF8 - Checks if scalar is valid UTF-8
Summary: Review Request: perl-Unicode-CheckUTF8 - Checks if scalar is valid UTF-8
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mario Blättermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 15:19 UTC by Paul Howarth
Modified: 2011-10-03 15:18 UTC (History)
3 users (show)

Fixed In Version: perl-Unicode-CheckUTF8-1.03-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 15:18:50 UTC
mario.blaettermann: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Paul Howarth 2011-08-24 15:19:48 UTC
Spec URL:
http://subversion.city-fan.org/repos/cfo-repo/perl-Unicode-CheckUTF8/branches/fedora/perl-Unicode-CheckUTF8.spec
SRPM URL:
http://www.city-fan.org/~paul/extras/perl-Unicode-CheckUTF8/perl-Unicode-CheckUTF8-1.03-2.fc17.src.rpm

Description:
This is an XS wrapper around some Unicode Consortium code to check if a string
is valid UTF-8, revised to conform to what expat/Mozilla think is valid UTF-8,
especially with regard to low-ASCII characters.

Note that this module has NOTHING to do with Perl's internal UTF8 flag on
scalars.

This module is for use when you're getting input from users and want to make
sure it's valid UTF-8 before continuing.

Comment 1 Mario Blättermann 2011-08-28 19:03:47 UTC
Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3307770

$ rpmlint -i -v *
perl-Unicode-CheckUTF8.i686: I: checking
perl-Unicode-CheckUTF8.i686: I: checking-url http://search.cpan.org/dist/Unicode-String/ (timeout 10 seconds)
perl-Unicode-CheckUTF8.src: I: checking
perl-Unicode-CheckUTF8.src: I: checking-url http://search.cpan.org/dist/Unicode-String/ (timeout 10 seconds)
perl-Unicode-CheckUTF8.src: E: unknown-key GPG#b56a8bac
The package was signed, but with an unknown key. See the rpm --import option
for more information.

perl-Unicode-CheckUTF8.src: I: checking-url http://search.cpan.org/CPAN/authors/id/B/BR/BRADFITZ/Unicode-CheckUTF8-1.03.tar.gz (timeout 10 seconds)
perl-Unicode-CheckUTF8.x86_64: I: checking
perl-Unicode-CheckUTF8.x86_64: I: checking-url http://search.cpan.org/dist/Unicode-String/ (timeout 10 seconds)
perl-Unicode-CheckUTF8-debuginfo.i686: I: checking
perl-Unicode-CheckUTF8-debuginfo.i686: I: checking-url http://search.cpan.org/dist/Unicode-String/ (timeout 10 seconds)
perl-Unicode-CheckUTF8-debuginfo.x86_64: I: checking
perl-Unicode-CheckUTF8-debuginfo.x86_64: I: checking-url http://search.cpan.org/dist/Unicode-String/ (timeout 10 seconds)
/home/mariobl/Arbeitsfläche/perl-Unicode-CheckUTF8/perl-Unicode-CheckUTF8-1.03-2.fc17.src/perl-Unicode-CheckUTF8.spec: I: checking-url http://search.cpan.org/CPAN/authors/id/B/BR/BRADFITZ/Unicode-CheckUTF8-1.03.tar.gz (timeout 10 seconds)
5 packages and 1 specfiles checked; 1 errors, 0 warnings.

The srpm has been signed, probably unintended... No further issues.


---------------------------------
key:

[+] OK
[.] OK, not applicable
[X] needs work
---------------------------------

[+] MUST: The package must be named according to the Package Naming Guidelines.
[+] MUST: The spec file name must match the base package %{name}.
[+] MUST: The package must meet the Packaging Guidelines.
[+] MUST: The package must be licensed with a Fedora approved license.
    UCD, GPL+ or Artistic
[+] MUST: The License field in the package spec file must match the actual
license.
[+] MUST: The file containing the text of the license(s) for the package must
be included in %doc.
[+] MUST: The spec file must be written in American English.
[+] MUST: The spec file for the package MUST be legible.
[+] MUST: The sources used to build the package must match the upstream source.
    $ md5sum *86e8e76883e4ef96820f893aab6ccdca  perl-Unicode-CheckUTF8.spec
    a483f665b2bc62d7737c209294e64e1e  Unicode-CheckUTF8-1.03.tar.gz
    a483f665b2bc62d7737c209294e64e1e  Unicode-CheckUTF8-1.03.tar.gz.packaged

[+] MUST: The package MUST successfully compile and build into binary rpms on
at least one primary architecture.
    - Succesful Koji build available.
[.] MUST: If the package does not successfully compile, build or work on an
architecture, ...
[+] MUST: All build dependencies must be listed in BuildRequires.
[.] MUST: The spec file MUST handle locales properly.
[.] MUST: If a package installs files below %{_datadir}/icons, the icon cache
must be updated.
[.] MUST: Packages storing shared library files (not just symlinks) must call
ldconfig in %post and %postun.
[.] MUST: Packages must NOT bundle copies of system libraries.
[.] MUST: If the package is designed to be relocatable, ...
[+] MUST: A package must own all directories that it creates. 
[+] MUST: A Fedora package must not list a file more than once in %files.
[+] MUST: Permissions on files must be set properly.
[+] MUST: Packages must not provide RPM dependency information when that
information is not global in nature, or are otherwise handled.
[.] MUST: When filtering automatically generated RPM dependency information,
the filtering system implemented by Fedora must be used.
[+] MUST: Each package must consistently use macros.
[+] MUST: The package must contain code, or permissable content.
[.] MUST: Large documentation files must go in a -doc subpackage.
[+] MUST: Files in %doc must not affect the runtime of the application.
[.] MUST: Header files must be in a -devel package.
[.] MUST: Static libraries must be in a -static package.
[.] MUST: If a package contains library files with a suffix (e.g.
libfoo.so.1.1), ...
[.] MUST: devel packages must require the base package using a fully versioned
dependency.
[.] MUST: Packages must NOT contain any .la libtool archives.
[.] MUST: Packages containing GUI applications must include a %{name}.desktop
file
[.] MUST: .desktop files must be properly installed with desktop-file-install
in the %install section.
[+] MUST: Packages must not own files or directories already owned by other
packages.
[+] MUST: All filenames in rpm packages must be valid UTF-8.

[.] SHOULD: If the source package does not include license text(s) as a
    separate file from upstream, the packager SHOULD query upstream...
[+] SHOULD: Timestamps of files should be preserved.
[+] SHOULD: The reviewer should test that the package builds in mock.
    See Koji build above (which uses mock anyway)
[+] SHOULD: The reviewer should test that the package functions as described.
    I assume the packager has tested it. Don't know how to test it on my
system.
[+] SHOULD: If scriptlets are used, those scriptlets must be sane.
[.] SHOULD: Usually, subpackages other than devel should require the base
package using a fully versioned dependency.
[.] SHOULD: pkgconfig(.pc) files should be placed in a -devel pkg.
[.] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin,
/usr/bin, or /usr/sbin ...
[+] SHOULD: Your package should contain man pages for binaries/scripts.

----------------

PACKAGE APPROVED

----------------

Comment 2 Paul Howarth 2011-09-03 21:13:18 UTC
New Package SCM Request
=======================
Package Name: perl-Unicode-CheckUTF8
Short Description: Checks if scalar is valid UTF-8
Owners: pghmcfc
Branches: EL-4 EL-5 EL-6 F-14 F-15 F-16
InitialCC: perl-sig

Comment 3 Gwyn Ciesla 2011-09-04 19:08:46 UTC
Git done (by process-git-requests).

Comment 4 Fedora Update System 2011-09-04 21:09:53 UTC
perl-Unicode-CheckUTF8-1.03-2.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/perl-Unicode-CheckUTF8-1.03-2.el4

Comment 5 Fedora Update System 2011-09-04 21:10:00 UTC
perl-Unicode-CheckUTF8-1.03-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Unicode-CheckUTF8-1.03-2.el5

Comment 6 Fedora Update System 2011-09-04 21:10:09 UTC
perl-Unicode-CheckUTF8-1.03-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/perl-Unicode-CheckUTF8-1.03-2.fc15

Comment 7 Fedora Update System 2011-09-04 21:10:18 UTC
perl-Unicode-CheckUTF8-1.03-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-Unicode-CheckUTF8-1.03-2.fc14

Comment 8 Fedora Update System 2011-09-04 21:10:26 UTC
perl-Unicode-CheckUTF8-1.03-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Unicode-CheckUTF8-1.03-2.fc16

Comment 9 Fedora Update System 2011-09-04 21:10:33 UTC
perl-Unicode-CheckUTF8-1.03-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Unicode-CheckUTF8-1.03-2.el6

Comment 10 Fedora Update System 2011-09-14 22:36:21 UTC
perl-Unicode-CheckUTF8-1.03-2.fc15 has been pushed to the Fedora 15 stable repository.

Comment 11 Fedora Update System 2011-09-14 22:40:18 UTC
perl-Unicode-CheckUTF8-1.03-2.fc14 has been pushed to the Fedora 14 stable repository.

Comment 12 Fedora Update System 2011-09-20 02:31:19 UTC
perl-Unicode-CheckUTF8-1.03-2.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 13 Fedora Update System 2011-09-20 02:31:29 UTC
perl-Unicode-CheckUTF8-1.03-2.el4 has been pushed to the Fedora EPEL 4 stable repository.

Comment 14 Fedora Update System 2011-09-20 02:33:10 UTC
perl-Unicode-CheckUTF8-1.03-2.el5 has been pushed to the Fedora EPEL 5 stable repository.

Comment 15 Fedora Update System 2011-09-30 19:36:30 UTC
perl-Unicode-CheckUTF8-1.03-2.fc16 has been pushed to the Fedora 16 stable repository.

Comment 16 Paul Howarth 2011-10-03 15:18:50 UTC
Package is now available for all currently-supported releases.


Note You need to log in before you can comment on or make changes to this bug.